summaryrefslogtreecommitdiff
path: root/sys-fs
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <Arfrever@Apache.Org>2018-03-21 03:27:40 +0100
committerTim Harder <radhermit@gentoo.org>2018-03-22 21:34:52 -0400
commitac9080851649f3d88fd86a47fbe7e40a08c507cf (patch)
tree47b0a435640831aa9a015e5eb94d84869a2c2bba /sys-fs
parentnet-mail/offlineimap: version bump to 7.1.5 (diff)
downloadgentoo-ac9080851649f3d88fd86a47fbe7e40a08c507cf.tar.gz
gentoo-ac9080851649f3d88fd86a47fbe7e40a08c507cf.tar.bz2
gentoo-ac9080851649f3d88fd86a47fbe7e40a08c507cf.zip
sys-fs/fuse: Use python-any-r1.eclass instead of python-single-r1.eclass.
Closes: https://bugs.gentoo.org/651048
Diffstat (limited to 'sys-fs')
-rw-r--r--sys-fs/fuse/fuse-3.2.1.ebuild18
1 files changed, 12 insertions, 6 deletions
diff --git a/sys-fs/fuse/fuse-3.2.1.ebuild b/sys-fs/fuse/fuse-3.2.1.ebuild
index 9da51f7e84cb..2514b6960a78 100644
--- a/sys-fs/fuse/fuse-3.2.1.ebuild
+++ b/sys-fs/fuse/fuse-3.2.1.ebuild
@@ -4,7 +4,7 @@
EAPI=6
PYTHON_COMPAT=( python3_{4,5,6} )
-inherit meson multilib-minimal flag-o-matic python-single-r1
+inherit meson multilib-minimal flag-o-matic python-any-r1
DESCRIPTION="An interface for filesystems implemented in userspace"
HOMEPAGE="https://github.com/libfuse/libfuse"
@@ -14,18 +14,24 @@ LICENSE="GPL-2 LGPL-2.1"
SLOT="3"
KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="test"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
DEPEND="virtual/pkgconfig
test? (
${PYTHON_DEPS}
- dev-python/pytest[${PYTHON_USEDEP}]
- )
- "
+ $(python_gen_any_dep 'dev-python/pytest[${PYTHON_USEDEP}]')
+ )"
RDEPEND="sys-fs/fuse-common"
DOCS=( AUTHORS ChangeLog.rst README.md doc/README.NFS doc/kernel.txt )
+python_check_deps() {
+ has_version "dev-python/pytest[${PYTHON_USEDEP}]"
+}
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
src_prepare() {
default
@@ -45,7 +51,7 @@ multilib_src_compile() {
}
multilib_src_test() {
- python3 -m pytest test || die
+ ${EPYTHON} -m pytest test || die
}
multilib_src_install() {