summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <crabbedhaloablution@icloud.com>2020-12-09 19:15:20 +0100
committerSam James <sam@gentoo.org>2020-12-15 03:05:49 +0000
commit993fbc04d12f14859517822cc660de2fc81dc7df (patch)
tree72be5f8738756de693417b00c102fac6f755ea10 /sys-kernel/raspberrypi-image/raspberrypi-image-5.4.79_p20201201.ebuild
parentdev-embedded/rpi-eeprom: Bump to 10.3_p1 (diff)
downloadgentoo-993fbc04d12f14859517822cc660de2fc81dc7df.tar.gz
gentoo-993fbc04d12f14859517822cc660de2fc81dc7df.tar.bz2
gentoo-993fbc04d12f14859517822cc660de2fc81dc7df.zip
sys-kernel/raspberrypi-image: version bump to 5.4.79_p20201201
Closes: https://bugs.gentoo.org/759265 Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Peter Alfredsen <crabbedhaloablution@icloud.com> Closes: https://github.com/gentoo/gentoo/pull/18582 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-kernel/raspberrypi-image/raspberrypi-image-5.4.79_p20201201.ebuild')
-rw-r--r--sys-kernel/raspberrypi-image/raspberrypi-image-5.4.79_p20201201.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-kernel/raspberrypi-image/raspberrypi-image-5.4.79_p20201201.ebuild b/sys-kernel/raspberrypi-image/raspberrypi-image-5.4.79_p20201201.ebuild
new file mode 100644
index 000000000000..dd284762191f
--- /dev/null
+++ b/sys-kernel/raspberrypi-image/raspberrypi-image-5.4.79_p20201201.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit mount-boot
+
+DESCRIPTION="Raspberry Pi (all versions) kernel and modules"
+HOMEPAGE="https://github.com/raspberrypi/firmware"
+LICENSE="GPL-2 raspberrypi-videocore-bin"
+SLOT="0"
+RESTRICT="binchecks strip"
+
+# Temporary safety measure to prevent ending up with a pair of
+# sys-kernel/raspberrypi-image and sys-boot/raspberrypi-firmware
+# both of which installed device tree files.
+# Restore to simply "sys-boot/raspberrypi-firmware" when the mentioned version
+# and all older ones are deleted.
+RDEPEND=">sys-boot/raspberrypi-firmware-1.20190709"
+
+if [[ "${PV}" == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/raspberrypi/firmware"
+ EGIT_CLONE_TYPE="shallow"
+else
+ [[ "$(ver_cut 4)" == 'p' ]] || die "Unsupported version format, tweak the ebuild."
+ MY_PV="1.$(ver_cut 5)"
+ SRC_URI="https://github.com/raspberrypi/firmware/archive/${MY_PV}.tar.gz -> raspberrypi-firmware-${MY_PV}.tar.gz"
+ S="${WORKDIR}/firmware-${MY_PV}"
+ KEYWORDS="-* ~arm ~arm64"
+fi
+
+src_install() {
+ insinto /lib/modules
+ doins -r modules/*
+ insinto /boot
+ doins boot/*.img
+
+ doins boot/*.dtb
+ doins -r boot/overlays
+}