summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-23 18:21:35 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-23 20:31:06 +0200
commit41b0c9f58de438f7a2729aa457bfa1ec03059083 (patch)
tree8fd1f272495e394c93df23ff9aa3a06f19d0bc27 /sys-kernel
parentmedia-radio/fldigi: add 4.1.27 (diff)
downloadgentoo-41b0c9f58de438f7a2729aa457bfa1ec03059083.tar.gz
gentoo-41b0c9f58de438f7a2729aa457bfa1ec03059083.tar.bz2
gentoo-41b0c9f58de438f7a2729aa457bfa1ec03059083.zip
sys-kernel/vanilla-kernel: Bump to 6.4.5
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-kernel')
-rw-r--r--sys-kernel/vanilla-kernel/Manifest2
-rw-r--r--sys-kernel/vanilla-kernel/vanilla-kernel-6.4.5.ebuild137
2 files changed, 139 insertions, 0 deletions
diff --git a/sys-kernel/vanilla-kernel/Manifest b/sys-kernel/vanilla-kernel/Manifest
index 734a9e5ef246..af5dffc90808 100644
--- a/sys-kernel/vanilla-kernel/Manifest
+++ b/sys-kernel/vanilla-kernel/Manifest
@@ -38,3 +38,5 @@ DIST linux-6.4.3.tar.sign 987 BLAKE2B 7e81fb9189b3416708fb91b04fea1a061264803c0d
DIST linux-6.4.3.tar.xz 137785616 BLAKE2B d38cae9706127fa28cc55b50ceeba7601de3d1db648b934b9d33e0b439324790074b755b1de204586fa098a326f5c88f81550cff76489b2ea6505987fc243c56 SHA512 67a280d4d50ed9d9ddae1ab35cf24c2e9ada2e09cda4e54e79508c5399b8be4f9528a8a8c18d9042fff0c11f0109eaaa3bd50bc7174831be381299180eb0a908
DIST linux-6.4.4.tar.sign 987 BLAKE2B 91ac93299fc5cebb017243efc23a21d666473d30dd112802d63da60ec013aa07891610f57f77e359e197c5dc759982a023388b8ddedcc0976aebd604122a0d2a SHA512 7c50f1024a735a17a61719d1c14c228dcd6720c4bb6a0bd6372269068f79c9352a8e4942e32ec3ba721c9e07cd5058ef5d5791c4a03e4350d2dd1688d862df6e
DIST linux-6.4.4.tar.xz 137809300 BLAKE2B 1ab6c93da986dac6a07a5e3bc764f9d2a5bb9b8989321244455d894690634ac04364e6a3f960e8674f47ae22fc4ed09b18aa60cbf279636083e61aa6524f8a59 SHA512 975752237ef7f1e0ed1dd912b9c864aea5003fee406502988105204c61ce867c93fd7e23c720361191641933bf083ff9798b448e1b2c4809338d4a6548fbf942
+DIST linux-6.4.5.tar.sign 987 BLAKE2B 02d4a298007444b3216531484845de2cc7a1b81a90cd7903adedd9c87b2f47e1e1fbbcbe385af093f2605a2a156fe259eea88f0ba2ffbd72180db24f42161195 SHA512 c64936702b665136eab61b9a14eeb557f58a99f12aaf617206fd4cdefe481cf4699e0b37f6dd4265279c39337eff0ad9230c367b331b025cc73b265197a82220
+DIST linux-6.4.5.tar.xz 137825176 BLAKE2B 2254e10d0780707591d25d5877dc946ba07b2f5a4f43063de55efea6724e267b1ab8f63329bec14431f4a4355fb4d474161c1d2c0c860d968630a3bb39e1a6e2 SHA512 23762ff366d13fbfb54daf01bd38e0e071bd4d559012b36cf96f041790553d1f3ca6e89c8cae8fb25e2986fa63a9422ed8e97a9e33f1805216815545ac9cc6e4
diff --git a/sys-kernel/vanilla-kernel/vanilla-kernel-6.4.5.ebuild b/sys-kernel/vanilla-kernel/vanilla-kernel-6.4.5.ebuild
new file mode 100644
index 000000000000..f500b95faca4
--- /dev/null
+++ b/sys-kernel/vanilla-kernel/vanilla-kernel-6.4.5.ebuild
@@ -0,0 +1,137 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit kernel-build toolchain-funcs verify-sig
+
+MY_P=linux-${PV}
+# https://koji.fedoraproject.org/koji/packageinfo?packageID=8
+# forked to https://github.com/projg2/fedora-kernel-config-for-gentoo
+CONFIG_VER=6.4.3-gentoo
+GENTOO_CONFIG_VER=g7
+
+DESCRIPTION="Linux kernel built from vanilla upstream sources"
+HOMEPAGE="
+ https://wiki.gentoo.org/wiki/Project:Distribution_Kernel
+ https://www.kernel.org/
+"
+SRC_URI+="
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.xz
+ https://github.com/projg2/gentoo-kernel-config/archive/${GENTOO_CONFIG_VER}.tar.gz
+ -> gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz
+ verify-sig? (
+ https://cdn.kernel.org/pub/linux/kernel/v$(ver_cut 1).x/${MY_P}.tar.sign
+ )
+ amd64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-x86_64-fedora.config
+ -> kernel-x86_64-fedora.config.${CONFIG_VER}
+ )
+ arm64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-aarch64-fedora.config
+ -> kernel-aarch64-fedora.config.${CONFIG_VER}
+ )
+ ppc64? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-ppc64le-fedora.config
+ -> kernel-ppc64le-fedora.config.${CONFIG_VER}
+ )
+ x86? (
+ https://raw.githubusercontent.com/projg2/fedora-kernel-config-for-gentoo/${CONFIG_VER}/kernel-i686-fedora.config
+ -> kernel-i686-fedora.config.${CONFIG_VER}
+ )
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug hardened"
+REQUIRED_USE="arm? ( savedconfig )"
+
+BDEPEND="
+ debug? ( dev-util/pahole )
+ verify-sig? ( sec-keys/openpgp-keys-kernel )
+"
+PDEPEND="
+ >=virtual/dist-kernel-${PV}
+"
+
+VERIFY_SIG_OPENPGP_KEY_PATH=${BROOT}/usr/share/openpgp-keys/kernel.org.asc
+
+src_unpack() {
+ if use verify-sig; then
+ einfo "Unpacking linux-${PV}.tar.xz ..."
+ verify-sig_verify_detached - "${DISTDIR}"/linux-${PV}.tar.sign \
+ < <(xz -cd "${DISTDIR}"/linux-${PV}.tar.xz | tee >(tar -x))
+ assert "Unpack failed"
+ unpack "gentoo-kernel-config-${GENTOO_CONFIG_VER}.tar.gz"
+ else
+ default
+ fi
+}
+
+src_prepare() {
+ default
+
+ local biendian=false
+
+ # prepare the default config
+ case ${ARCH} in
+ amd64)
+ cp "${DISTDIR}/kernel-x86_64-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ arm)
+ return
+ ;;
+ arm64)
+ cp "${DISTDIR}/kernel-aarch64-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ hppa)
+ return
+ ;;
+ ppc)
+ # assume powermac/powerbook defconfig
+ # we still package.use.force savedconfig
+ cp "${WORKDIR}/${MY_P}/arch/powerpc/configs/pmac32_defconfig" .config || die
+ ;;
+ ppc64)
+ cp "${DISTDIR}/kernel-ppc64le-fedora.config.${CONFIG_VER}" .config || die
+ biendian=true
+ ;;
+ x86)
+ cp "${DISTDIR}/kernel-i686-fedora.config.${CONFIG_VER}" .config || die
+ ;;
+ *)
+ die "Unsupported arch ${ARCH}"
+ ;;
+ esac
+
+ local myversion="-dist"
+ use hardened && myversion+="-hardened"
+ echo "CONFIG_LOCALVERSION=\"${myversion}\"" > "${T}"/version.config || die
+ local dist_conf_path="${WORKDIR}/gentoo-kernel-config-${GENTOO_CONFIG_VER}"
+
+ local merge_configs=(
+ "${T}"/version.config
+ "${dist_conf_path}"/base.config
+ )
+ use debug || merge_configs+=(
+ "${dist_conf_path}"/no-debug.config
+ )
+ if use hardened; then
+ merge_configs+=( "${dist_conf_path}"/hardened-base.config )
+
+ tc-is-gcc && merge_configs+=( "${dist_conf_path}"/hardened-gcc-plugins.config )
+
+ if [[ -f "${dist_conf_path}/hardened-${ARCH}.config" ]]; then
+ merge_configs+=( "${dist_conf_path}/hardened-${ARCH}.config" )
+ fi
+ fi
+
+ # this covers ppc64 and aarch64_be only for now
+ if [[ ${biendian} == true && $(tc-endian) == big ]]; then
+ merge_configs+=( "${dist_conf_path}/big-endian.config" )
+ fi
+
+ kernel-build_merge_configs "${merge_configs[@]}"
+}