summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAric Belsito <lluixhi@gmail.com>2017-01-19 12:23:24 -0800
committerAnthony G. Basile <blueness@gentoo.org>2017-01-21 08:27:36 -0500
commitcb196546c62e9894a46900e8078f753388d4cc1a (patch)
treee42980fc7fee7936bae95418df1b8533fa531315 /sys-libs/argp-standalone/argp-standalone-1.3-r2.ebuild
parentapp-text/texlive: Bump to TeX Live 2016. (diff)
downloadgentoo-cb196546c62e9894a46900e8078f753388d4cc1a.tar.gz
gentoo-cb196546c62e9894a46900e8078f753388d4cc1a.tar.bz2
gentoo-cb196546c62e9894a46900e8078f753388d4cc1a.zip
sys-libs/argp-standalone: Revbump to build shared
Update to EAPI 6 Patch is from Debian
Diffstat (limited to 'sys-libs/argp-standalone/argp-standalone-1.3-r2.ebuild')
-rw-r--r--sys-libs/argp-standalone/argp-standalone-1.3-r2.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/sys-libs/argp-standalone/argp-standalone-1.3-r2.ebuild b/sys-libs/argp-standalone/argp-standalone-1.3-r2.ebuild
new file mode 100644
index 000000000000..8b78bacb7e98
--- /dev/null
+++ b/sys-libs/argp-standalone/argp-standalone-1.3-r2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="Standalone argp library for use with uclibc"
+HOMEPAGE="http://www.lysator.liu.se/~nisse/misc/"
+SRC_URI="http://www.lysator.liu.se/~nisse/misc/argp-standalone-1.3.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~m68k ~mips ~ppc ~s390 ~sh ~x86"
+IUSE="static-libs"
+
+DEPEND="!sys-libs/glibc"
+
+PATCHES=(
+ "${FILESDIR}/${P}-throw-in-funcdef.patch"
+ "${FILESDIR}/${P}-shared.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags "-fgnu89-inline"
+ econf \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+ insinto /usr/include
+ doins argp.h
+}