summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBenda Xu <heroxbd@gentoo.org>2019-04-13 18:08:52 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2019-04-13 18:13:40 +0200
commitf99af4631f3251f9e10cbd048ab8638e027fe1b2 (patch)
treede25f03ca69c4b3650c2f5c638e9c64b42795941 /sys-libs/glibc
parentfeatures/selinux/package.mask: mask package relying on gnome-shell-extensions (diff)
downloadgentoo-f99af4631f3251f9e10cbd048ab8638e027fe1b2.tar.gz
gentoo-f99af4631f3251f9e10cbd048ab8638e027fe1b2.tar.bz2
gentoo-f99af4631f3251f9e10cbd048ab8638e027fe1b2.zip
sys-libs/glibc: python pkg_setup fails during bootstrap.
Glibc-2.29 introduces a new python dependency for building. However, during Prefix bootstrap, glibc has to be built before python. The dependency circle is broken by disabling pkg_setup() of python-any-r1.eclass. Bug: https://bugs.gentoo.org/682570 Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Benda Xu <heroxbd@gentoo.org> Signed-off-by: Andreas K. Hüttel <dilfridge@gentoo.org>
Diffstat (limited to 'sys-libs/glibc')
-rw-r--r--sys-libs/glibc/glibc-2.29-r2.ebuild4
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild4
2 files changed, 8 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-2.29-r2.ebuild b/sys-libs/glibc/glibc-2.29-r2.ebuild
index e675e2b5c146..0e1db7e3c853 100644
--- a/sys-libs/glibc/glibc-2.29-r2.ebuild
+++ b/sys-libs/glibc/glibc-2.29-r2.ebuild
@@ -719,6 +719,10 @@ pkg_pretend() {
sanity_prechecks
}
+pkg_setup() {
+ [[ -z ${BOOTSTRAP_RAP} ]] && python-any-r1_pkg_setup
+}
+
# src_unpack
src_unpack() {
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 478b5e5c9dc6..ba1d5041cb74 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -720,6 +720,10 @@ pkg_pretend() {
sanity_prechecks
}
+pkg_setup() {
+ [[ -z ${BOOTSTRAP_RAP} ]] && python-any-r1_pkg_setup
+}
+
# src_unpack
src_unpack() {