summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-05-13 05:23:45 +0000
committerSam James <sam@gentoo.org>2022-05-13 18:26:48 +0000
commit9b0d147c296144236fa653145ac454130586d594 (patch)
tree2741243031ba62943c531ea286e1c66126e7c9bd /sys-libs
parentdev-lang/php: Version bump for 8.0.19 (diff)
downloadgentoo-9b0d147c296144236fa653145ac454130586d594.tar.gz
gentoo-9b0d147c296144236fa653145ac454130586d594.tar.bz2
gentoo-9b0d147c296144236fa653145ac454130586d594.zip
sys-libs/glibc: filter -fsanitize=*
Just like with gcc. (noticed when had CFLAGS set in env accidentally) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/glibc/glibc-9999.ebuild5
1 files changed, 5 insertions, 0 deletions
diff --git a/sys-libs/glibc/glibc-9999.ebuild b/sys-libs/glibc/glibc-9999.ebuild
index 0ccad6a681c1..07bdba5ad0ed 100644
--- a/sys-libs/glibc/glibc-9999.ebuild
+++ b/sys-libs/glibc/glibc-9999.ebuild
@@ -429,8 +429,13 @@ setup_flags() {
# include/libc-symbols.h:75:3: #error "glibc cannot be compiled without optimization"
replace-flags -O0 -O1
+ # glibc handles this internally already where it's appropriate;
+ # can't always have SSP when we're the ones setting it up, etc
filter-flags '-fstack-protector*'
+ # Similar issues as with SSP. Can't inject yourself that early.
+ filter-flags '-fsanitize=*'
+
# See end of bug #830454; we handle this via USE=cet
filter-flags '-fcf-protection='
}