summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-10 12:00:40 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-10 12:13:07 +0100
commitdfa28b3246e07a048cd5af9f0ec41159698af9fb (patch)
tree54e7ecad97a27049e5fe46b33e6e888922dd358b /sys-libs
parentsys-libs/compiler-rt: Migrate to llvm-utils (diff)
downloadgentoo-dfa28b3246e07a048cd5af9f0ec41159698af9fb.tar.gz
gentoo-dfa28b3246e07a048cd5af9f0ec41159698af9fb.tar.bz2
gentoo-dfa28b3246e07a048cd5af9f0ec41159698af9fb.zip
sys-libs/compiler-rt-sanitizers: Migrate to llvm-utils
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-18.1.0_rc2.ebuild5
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.0.0.9999.ebuild5
-rw-r--r--sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.0.0_pre20240203.ebuild5
3 files changed, 9 insertions, 6 deletions
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-18.1.0_rc2.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-18.1.0_rc2.ebuild
index 2ab1ae07e4c7..57f868d54be6 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-18.1.0_rc2.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-18.1.0_rc2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit check-reqs cmake flag-o-matic llvm llvm.org python-any-r1
+inherit check-reqs cmake flag-o-matic llvm.org llvm-utils python-any-r1
DESCRIPTION="Compiler runtime libraries for clang (sanitizers & xray)"
HOMEPAGE="https://llvm.org/"
@@ -72,7 +72,6 @@ pkg_pretend() {
pkg_setup() {
check_space
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
python-any-r1_pkg_setup
}
@@ -102,6 +101,8 @@ src_prepare() {
}
src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.0.0.9999.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.0.0.9999.ebuild
index 2ab1ae07e4c7..57f868d54be6 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.0.0.9999.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.0.0.9999.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit check-reqs cmake flag-o-matic llvm llvm.org python-any-r1
+inherit check-reqs cmake flag-o-matic llvm.org llvm-utils python-any-r1
DESCRIPTION="Compiler runtime libraries for clang (sanitizers & xray)"
HOMEPAGE="https://llvm.org/"
@@ -72,7 +72,6 @@ pkg_pretend() {
pkg_setup() {
check_space
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
python-any-r1_pkg_setup
}
@@ -102,6 +101,8 @@ src_prepare() {
}
src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"
diff --git a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.0.0_pre20240203.ebuild b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.0.0_pre20240203.ebuild
index 2ab1ae07e4c7..57f868d54be6 100644
--- a/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.0.0_pre20240203.ebuild
+++ b/sys-libs/compiler-rt-sanitizers/compiler-rt-sanitizers-19.0.0_pre20240203.ebuild
@@ -4,7 +4,7 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit check-reqs cmake flag-o-matic llvm llvm.org python-any-r1
+inherit check-reqs cmake flag-o-matic llvm.org llvm-utils python-any-r1
DESCRIPTION="Compiler runtime libraries for clang (sanitizers & xray)"
HOMEPAGE="https://llvm.org/"
@@ -72,7 +72,6 @@ pkg_pretend() {
pkg_setup() {
check_space
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
python-any-r1_pkg_setup
}
@@ -102,6 +101,8 @@ src_prepare() {
}
src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
# LLVM_ENABLE_ASSERTIONS=NO does not guarantee this for us, #614844
use debug || local -x CPPFLAGS="${CPPFLAGS} -DNDEBUG"