summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-10 12:05:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-10 12:13:10 +0100
commitf236074cd4d5cb8f6496235f4b0a934292b73986 (patch)
treee63669bc885ce5964cf55040cbc62486c5817fe2 /sys-libs
parentsys-libs/libcxxabi: Migrate to llvm-utils (diff)
downloadgentoo-f236074cd4d5cb8f6496235f4b0a934292b73986.tar.gz
gentoo-f236074cd4d5cb8f6496235f4b0a934292b73986.tar.bz2
gentoo-f236074cd4d5cb8f6496235f4b0a934292b73986.zip
sys-libs/libcxx: Migrate to llvm-utils
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-libs')
-rw-r--r--sys-libs/libcxx/libcxx-18.1.0_rc2.ebuild12
-rw-r--r--sys-libs/libcxx/libcxx-19.0.0.9999.ebuild12
-rw-r--r--sys-libs/libcxx/libcxx-19.0.0_pre20240203.ebuild12
3 files changed, 12 insertions, 24 deletions
diff --git a/sys-libs/libcxx/libcxx-18.1.0_rc2.ebuild b/sys-libs/libcxx/libcxx-18.1.0_rc2.ebuild
index a24b477a5ab8..c205f3f21b57 100644
--- a/sys-libs/libcxx/libcxx-18.1.0_rc2.ebuild
+++ b/sys-libs/libcxx/libcxx-18.1.0_rc2.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib flag-o-matic llvm.org llvm-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
@@ -48,12 +48,6 @@ python_check_deps() {
}
pkg_setup() {
- # Darwin Prefix builds do not have llvm installed yet, so rely on
- # bootstrap-prefix to set the appropriate path vars to LLVM instead
- # of using llvm_pkg_setup.
- if [[ ${CHOST} != *-darwin* ]] || has_version sys-devel/llvm; then
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
- fi
python-any-r1_pkg_setup
if ! use libcxxabi && ! tc-is-gcc ; then
@@ -79,6 +73,8 @@ test_compiler() {
}
src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
# note: we need to do this before multilib kicks in since it will
# alter the CHOST
local cxxabi cxxabi_incs
diff --git a/sys-libs/libcxx/libcxx-19.0.0.9999.ebuild b/sys-libs/libcxx/libcxx-19.0.0.9999.ebuild
index a24b477a5ab8..c205f3f21b57 100644
--- a/sys-libs/libcxx/libcxx-19.0.0.9999.ebuild
+++ b/sys-libs/libcxx/libcxx-19.0.0.9999.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib flag-o-matic llvm.org llvm-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
@@ -48,12 +48,6 @@ python_check_deps() {
}
pkg_setup() {
- # Darwin Prefix builds do not have llvm installed yet, so rely on
- # bootstrap-prefix to set the appropriate path vars to LLVM instead
- # of using llvm_pkg_setup.
- if [[ ${CHOST} != *-darwin* ]] || has_version sys-devel/llvm; then
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
- fi
python-any-r1_pkg_setup
if ! use libcxxabi && ! tc-is-gcc ; then
@@ -79,6 +73,8 @@ test_compiler() {
}
src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
# note: we need to do this before multilib kicks in since it will
# alter the CHOST
local cxxabi cxxabi_incs
diff --git a/sys-libs/libcxx/libcxx-19.0.0_pre20240203.ebuild b/sys-libs/libcxx/libcxx-19.0.0_pre20240203.ebuild
index a24b477a5ab8..c205f3f21b57 100644
--- a/sys-libs/libcxx/libcxx-19.0.0_pre20240203.ebuild
+++ b/sys-libs/libcxx/libcxx-19.0.0_pre20240203.ebuild
@@ -4,8 +4,8 @@
EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
-inherit cmake-multilib flag-o-matic llvm llvm.org python-any-r1 \
- toolchain-funcs
+inherit cmake-multilib flag-o-matic llvm.org llvm-utils python-any-r1
+inherit toolchain-funcs
DESCRIPTION="New implementation of the C++ standard library, targeting C++11"
HOMEPAGE="https://libcxx.llvm.org/"
@@ -48,12 +48,6 @@ python_check_deps() {
}
pkg_setup() {
- # Darwin Prefix builds do not have llvm installed yet, so rely on
- # bootstrap-prefix to set the appropriate path vars to LLVM instead
- # of using llvm_pkg_setup.
- if [[ ${CHOST} != *-darwin* ]] || has_version sys-devel/llvm; then
- LLVM_MAX_SLOT=${LLVM_MAJOR} llvm_pkg_setup
- fi
python-any-r1_pkg_setup
if ! use libcxxabi && ! tc-is-gcc ; then
@@ -79,6 +73,8 @@ test_compiler() {
}
src_configure() {
+ llvm_prepend_path "${LLVM_MAJOR}"
+
# note: we need to do this before multilib kicks in since it will
# alter the CHOST
local cxxabi cxxabi_incs