summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJay Faulkner <jay@jvf.cc>2024-10-18 14:57:19 -0700
committerYixun Lan <dlan@gentoo.org>2024-10-25 15:31:40 +0800
commit1ca4274ed7925716421aa0a2eb481d22b69ed1dd (patch)
tree65246074f83d77fd880fda7445c4a9b73d8fb415 /sys-power
parentmedia-gfx/librecad: update live (diff)
downloadgentoo-1ca4274ed7925716421aa0a2eb481d22b69ed1dd.tar.gz
gentoo-1ca4274ed7925716421aa0a2eb481d22b69ed1dd.tar.bz2
gentoo-1ca4274ed7925716421aa0a2eb481d22b69ed1dd.zip
sys-power/tlp: add 1.7.0
Closes: https://github.com/gentoo/gentoo/pull/39037 Signed-off-by: Jay Faulkner <jay@jvf.cc> Signed-off-by: Yixun Lan <dlan@gentoo.org>
Diffstat (limited to 'sys-power')
-rw-r--r--sys-power/tlp/Manifest1
-rw-r--r--sys-power/tlp/tlp-1.7.0.ebuild50
2 files changed, 51 insertions, 0 deletions
diff --git a/sys-power/tlp/Manifest b/sys-power/tlp/Manifest
index 798da5e2b3d3..20427738d53d 100644
--- a/sys-power/tlp/Manifest
+++ b/sys-power/tlp/Manifest
@@ -1 +1,2 @@
DIST tlp-1.6.1.tar.gz 143688 BLAKE2B e7ddc8c792bf9911204556f6845da27e0c8722b5dc25b4b855c044a7d6b27662b6bad607532b631ea3766651f43321fda21ca1b51a01955d113ba838700d0182 SHA512 de88c4b4ae7d742eeec2bce7e43ccd99f971620541edc416471a46cb76a4f0c072821348d6c7f7fc44e7c70f2e3cde231d74546424ece533b2b2f531aee22b79
+DIST tlp-1.7.0.tar.gz 151003 BLAKE2B 3dbd600921fe29d6adc4d195000087c969b4be8f8c3b6052cf411ad820f06c47e31e2cf93a0c33f822491f1cf2420fd6cf1193d45846b067975b4efbb3e5407e SHA512 db6777dff1b253f63941271d39b3785646ad15b4351a4a647ec748d9beabcc891b70d4070d0ce5b01919024e7560eac6ee858b720f8ec0a5535c51513ccf7a3d
diff --git a/sys-power/tlp/tlp-1.7.0.ebuild b/sys-power/tlp/tlp-1.7.0.ebuild
new file mode 100644
index 000000000000..6f8ae18fd40d
--- /dev/null
+++ b/sys-power/tlp/tlp-1.7.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit udev optfeature
+
+DESCRIPTION="Optimize laptop battery life"
+HOMEPAGE="https://linrunner.de/tlp/"
+SRC_URI="https://github.com/linrunner/TLP/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/TLP-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# It's uncertain if elogind/systemd is actually required, however, without the sleep
+# hooks working, which require one of them, it doesn't seem like this app is very useful.
+RDEPEND="
+ dev-lang/perl
+ virtual/udev
+ || ( sys-auth/elogind sys-apps/systemd )
+"
+
+src_install() {
+ # NOTE(JayF): TLP_WITH_ELOGIND/TLP_WITH_SYSTEMD are both only installing
+ # small init/config files.
+ emake \
+ DESTDIR="${D}" \
+ TLP_NO_INIT=1 \
+ TLP_ELOD=/$(get_libdir)/elogind/system-sleep \
+ TLP_WITH_ELOGIND=1 \
+ TLP_WITH_SYSTEMD=1 \
+ install install-man
+
+ fperms 444 /usr/share/tlp/defaults.conf # manpage says this file should not be edited
+ newinitd "${FILESDIR}/tlp.init" tlp
+ keepdir /var/lib/tlp # created by Makefile, probably important
+}
+
+pkg_postinst() {
+ udev_reload
+
+ optfeature "disable Wake-on-LAN" sys-apps/ethtool
+ optfeature "see disk drive health info in tlp-stat" sys-apps/smartmontools
+}
+
+pkg_postrm() {
+ udev_reload
+}