summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-20 02:30:30 +0000
committerSam James <sam@gentoo.org>2021-12-20 04:08:35 +0000
commit15e061e8643f68741540b6020777898f9df2d7cb (patch)
tree1774eb252ae68e485d5bdf6ed4b46154bad4a233 /sys-process/atop/files
parentdev-python/numpy: add 1.21.5 (diff)
downloadgentoo-15e061e8643f68741540b6020777898f9df2d7cb.tar.gz
gentoo-15e061e8643f68741540b6020777898f9df2d7cb.tar.bz2
gentoo-15e061e8643f68741540b6020777898f9df2d7cb.zip
sys-process/atop: add 2.7.0
Closes: https://bugs.gentoo.org/612248 Closes: https://bugs.gentoo.org/736406 Closes: https://bugs.gentoo.org/777903 Closes: https://bugs.gentoo.org/829356 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/atop/files')
-rw-r--r--sys-process/atop/files/atop-2.7.0-netatop-makefile.patch42
-rw-r--r--sys-process/atop/files/atop.service-r111
-rw-r--r--sys-process/atop/files/netatop.rc17
3 files changed, 70 insertions, 0 deletions
diff --git a/sys-process/atop/files/atop-2.7.0-netatop-makefile.patch b/sys-process/atop/files/atop-2.7.0-netatop-makefile.patch
new file mode 100644
index 000000000000..bd2f17658cf8
--- /dev/null
+++ b/sys-process/atop/files/atop-2.7.0-netatop-makefile.patch
@@ -0,0 +1,42 @@
+--- a/daemon/Makefile
++++ b/daemon/Makefile
+@@ -6,7 +6,7 @@
+ all: netatopd
+
+ netatopd: netatopd.o Makefile
+- $(CC) netatopd.o -o netatopd -lz
++ $(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) netatopd.o -o netatopd -lz
+
+ clean:
+ rm -f *.o netatopd
+--- a/Makefile
++++ b/Makefile
+@@ -1,7 +1,7 @@
+ all:
+ ./mkversion
+- cd module; make
+- cd daemon; make
++ cd module; $(MAKE)
++ cd daemon; $(MAKE)
+
+ install: module/netatop.ko daemon/netatopd
+ install -d /lib/modules/`uname -r`/extra
+@@ -14,5 +14,5 @@
+ install man/netatopd.8 -t /usr/share/man/man8
+
+ clean:
+- cd module; make clean
+- cd daemon; make clean
++ cd module; $(MAKE) clean
++ cd daemon; $(MAKE) clean
+--- a/module/Makefile
++++ b/module/Makefile
+@@ -7,7 +7,7 @@
+
+ $(MYMODULE).ko: $(MYMODULE).c
+ echo start the make
+- make -C $(KERNDIR) M=$(THISDIR) modules
++ $(MAKE) -C $(KERNDIR) M=$(THISDIR) modules
+
+ clean:
+ rm -f *.o *.ko
diff --git a/sys-process/atop/files/atop.service-r1 b/sys-process/atop/files/atop.service-r1
new file mode 100644
index 000000000000..ba1575ba835e
--- /dev/null
+++ b/sys-process/atop/files/atop.service-r1
@@ -0,0 +1,11 @@
+[Unit]
+Description=Atop advanced performance monitor
+Documentation=man:atop(1)
+
+[Service]
+Type=simple
+ExecStart=/usr/share/atop/atop.daily
+KillSignal=SIGUSR2
+
+[Install]
+WantedBy=multi-user.target
diff --git a/sys-process/atop/files/netatop.rc b/sys-process/atop/files/netatop.rc
new file mode 100644
index 000000000000..9f02fab4bcd3
--- /dev/null
+++ b/sys-process/atop/files/netatop.rc
@@ -0,0 +1,17 @@
+#!/sbin/openrc-run
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+command="/usr/sbin/netatopd"
+procname="netatopd"
+
+depend() {
+ before atop atopacct
+}
+
+start_pre() {
+ modprobe netatop > /dev/null 2>&1
+}
+
+stop_post() {
+ rmmod netatop > /dev/null 2>&1
+}