summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-09-23 01:36:23 +0100
committerSam James <sam@gentoo.org>2022-09-23 01:36:23 +0100
commit26428b61fa8dbab55a1fbfea3a6d6e67565a12a4 (patch)
tree715b651c3117b4369e3b8d6c2247c1d431bec413 /sys-process/cronie
parentdev-util/ctags: fix automagic seccomp dep (diff)
downloadgentoo-26428b61fa8dbab55a1fbfea3a6d6e67565a12a4.tar.gz
gentoo-26428b61fa8dbab55a1fbfea3a6d6e67565a12a4.tar.bz2
gentoo-26428b61fa8dbab55a1fbfea3a6d6e67565a12a4.zip
sys-process/cronie: drop 1.5.7, 1.6.0-r2
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/cronie')
-rw-r--r--sys-process/cronie/Manifest2
-rw-r--r--sys-process/cronie/cronie-1.5.7.ebuild116
-rw-r--r--sys-process/cronie/cronie-1.6.0-r2.ebuild119
-rw-r--r--sys-process/cronie/files/cronie-1.6.0-crontab_entries_regression.patch21
4 files changed, 0 insertions, 258 deletions
diff --git a/sys-process/cronie/Manifest b/sys-process/cronie/Manifest
index ad71e811a63a..7de940b99a44 100644
--- a/sys-process/cronie/Manifest
+++ b/sys-process/cronie/Manifest
@@ -1,3 +1 @@
-DIST cronie-1.5.7.tar.gz 148739 BLAKE2B 3e9f8b78a29d2304e2ece7ce2b794b80e6023428d5b07f21936f3690eae2741b9e6814f966d8e3cb3d4f9daf32b3fe730ce6adebb76f8779c3f5039d2a19b6a4 SHA512 cddf1ffd518bf8daed8ae2634ace41da669f6d1039b1936b602200e2f2902944d8e84c80f73f6ab67b2fa755c4192f9181cf44d87bc893201b756367ab55148e
-DIST cronie-1.6.0.tar.gz 149859 BLAKE2B 0b63b07d8138c74c57ff0cbe1ae3cd3abb21178116322327d06cbc5e12a0c54e5f2512fb9f810787721f7ad1bba897f206b96fd83645bbfeeace734eedbcaf3d SHA512 9d078e2f8ffc0d2feaa16d419fcccf354f8de8021869b14d315b6f0a0acbd888da98fb47888b71672354ec221bbbaf5b77a543b909ae44b0fc6d2b39394ddf5b
DIST cronie-1.6.1.tar.gz 149913 BLAKE2B 7b563b90f386a8df09398661e2b3ddc1f83d6c0d19290a02c0622be461e1d160218572adf132d634c60ef8fd0a4bb100e830b90e26270c28c75a69591ccc18a6 SHA512 1e095df9670ec25d6629f4cf2cacd82c6c1cb1487a859815a7881a1d130e4f18f9976396f773abae24dadc232166bb6467bbaeac1cb0254209fcadf3530d5e6f
diff --git a/sys-process/cronie/cronie-1.5.7.ebuild b/sys-process/cronie/cronie-1.5.7.ebuild
deleted file mode 100644
index e4bba82a5797..000000000000
--- a/sys-process/cronie/cronie-1.5.7.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools cron flag-o-matic pam systemd
-
-DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
-HOMEPAGE="https://github.com/cronie-crond/cronie"
-SRC_URI="https://github.com/cronie-crond/cronie/archive/${P}.tar.gz"
-
-LICENSE="ISC BSD BSD-2 GPL-2"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-IUSE="+anacron +inotify pam selinux"
-
-DEPEND="
- acct-group/crontab
- pam? ( sys-libs/pam )
- anacron? (
- !sys-process/anacron
- !sys-process/systemd-cron
- elibc_musl? ( sys-libs/obstack-standalone )
- )
-"
-RDEPEND="${DEPEND}
- sys-apps/debianutils
-"
-
-#cronie supports /etc/crontab
-CRON_SYSTEM_CRONTAB="yes"
-
-S="${WORKDIR}/${PN}-${P}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.5.3-systemd.patch"
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with inotify)
- $(use_with pam)
- $(use_with selinux)
- $(use_enable anacron)
- --enable-syscrontab
- --with-daemon_username=cron
- --with-daemon_groupname=cron
- )
-
- if use anacron ; then
- if use elibc_musl ; then
- append-cflags "-lobstack"
- fi
- fi
- SPOOL_DIR="/var/spool/cron/crontabs" \
- ANACRON_SPOOL_DIR="/var/spool/anacron" \
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- docrondir -m 1730 -o root -g crontab
- fowners root:crontab /usr/bin/crontab
- fperms 2751 /usr/bin/crontab
-
- newconfd "${S}"/crond.sysconfig ${PN}
-
- insinto /etc
- newins "${FILESDIR}/${PN}-crontab" crontab
- newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
-
- insinto /etc/cron.d
- doins contrib/0hourly
-
- newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
-
- if use pam ; then
- newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
- fi
-
- systemd_newunit contrib/cronie.systemd cronie.service
-
- if use anacron ; then
- local anacrondir="/var/spool/anacron"
- keepdir ${anacrondir}
- fowners root:cron ${anacrondir}
- fperms 0750 ${anacrondir}
-
- insinto /etc
- doins contrib/anacrontab
-
- insinto /etc/cron.hourly
- doins contrib/0anacron
- fperms 0750 /etc/cron.hourly/0anacron
- else
- insinto /etc/cron.d
- doins contrib/dailyjobs
- fi
-
- einstalldocs
-}
-
-pkg_postinst() {
- cron_pkg_postinst
-
- if [[ -n "${REPLACING_VERSIONS}" ]] ; then
- ewarn "You should restart ${PN} daemon or else you might experience segfaults"
- ewarn "or ${PN} not working reliably anymore."
- einfo "(see https://bugs.gentoo.org/557406 for details.)"
- fi
-}
diff --git a/sys-process/cronie/cronie-1.6.0-r2.ebuild b/sys-process/cronie/cronie-1.6.0-r2.ebuild
deleted file mode 100644
index 6f15a911b057..000000000000
--- a/sys-process/cronie/cronie-1.6.0-r2.ebuild
+++ /dev/null
@@ -1,119 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-inherit autotools cron flag-o-matic pam systemd
-
-DESCRIPTION="Cronie is a standard UNIX daemon cron based on the original vixie-cron"
-HOMEPAGE="https://github.com/cronie-crond/cronie"
-SRC_URI="https://github.com/cronie-crond/cronie/archive/${P}.tar.gz"
-
-LICENSE="ISC BSD BSD-2 GPL-2"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
-IUSE="+anacron +inotify pam selinux"
-
-DEPEND="
- acct-group/crontab
- pam? ( sys-libs/pam )
- anacron? (
- !sys-process/anacron
- !sys-process/systemd-cron
- elibc_musl? ( sys-libs/obstack-standalone )
- )
-"
-RDEPEND="${DEPEND}
- sys-apps/debianutils
-"
-
-#cronie supports /etc/crontab
-CRON_SYSTEM_CRONTAB="yes"
-
-S="${WORKDIR}/${PN}-${P}"
-
-PATCHES=(
- "${FILESDIR}/${PN}-1.5.3-systemd.patch"
- "${FILESDIR}/${P}-crontab_entries_regression.patch" #836888
-)
-
-src_prepare() {
- default
- eautoreconf
-}
-
-src_configure() {
- local myeconfargs=(
- $(use_with inotify)
- $(use_with pam)
- $(use_with selinux)
- $(use_enable anacron)
- --enable-syscrontab
- # Required for correct pidfile location #835814
- --runstatedir="${EPREFIX}/run"
- --with-daemon_username=cron
- --with-daemon_groupname=cron
- )
-
- if use anacron ; then
- if use elibc_musl ; then
- append-cflags "-lobstack"
- fi
- fi
- SPOOL_DIR="/var/spool/cron/crontabs" \
- ANACRON_SPOOL_DIR="/var/spool/anacron" \
- econf "${myeconfargs[@]}"
-}
-
-src_install() {
- default
-
- docrondir -m 1730 -o root -g crontab
- fowners root:crontab /usr/bin/crontab
- fperms 2751 /usr/bin/crontab
-
- newconfd "${S}"/crond.sysconfig ${PN}
-
- insinto /etc
- newins "${FILESDIR}/${PN}-crontab" crontab
- newins "${FILESDIR}/${PN}-1.2-cron.deny" cron.deny
-
- insinto /etc/cron.d
- doins contrib/dailyjobs
-
- newinitd "${FILESDIR}/${PN}-1.3-initd" ${PN}
-
- if use pam ; then
- newpamd "${FILESDIR}/${PN}-1.4.3-pamd" crond
- fi
-
- systemd_newunit contrib/cronie.systemd cronie.service
-
- if use anacron ; then
- local anacrondir="/var/spool/anacron"
- keepdir ${anacrondir}
- fowners root:cron ${anacrondir}
- fperms 0750 ${anacrondir}
-
- insinto /etc
- doins contrib/anacrontab
-
- insinto /etc/cron.hourly
- doins contrib/0anacron
- fperms 0750 /etc/cron.hourly/0anacron
-
- insinto /etc/cron.d
- doins contrib/0hourly
- fi
-
- einstalldocs
-}
-
-pkg_postinst() {
- cron_pkg_postinst
-
- if [[ -n "${REPLACING_VERSIONS}" ]] ; then
- ewarn "You should restart ${PN} daemon or else you might experience segfaults"
- ewarn "or ${PN} not working reliably anymore."
- einfo "(see https://bugs.gentoo.org/557406 for details.)"
- fi
-}
diff --git a/sys-process/cronie/files/cronie-1.6.0-crontab_entries_regression.patch b/sys-process/cronie/files/cronie-1.6.0-crontab_entries_regression.patch
deleted file mode 100644
index 160c03116415..000000000000
--- a/sys-process/cronie/files/cronie-1.6.0-crontab_entries_regression.patch
+++ /dev/null
@@ -1,21 +0,0 @@
-From 62e53f1cdb9c1e12a01ee7814c92cd937d50328d Mon Sep 17 00:00:00 2001
-From: w30023233 <wangyuhang27@huawei.com>
-Date: Wed, 23 Mar 2022 15:40:01 +0800
-Subject: [PATCH] Fix regression in handling 1-5 crontab entries
-
----
- src/entry.c | 1 +
- 1 file changed, 1 insertion(+)
-
-diff --git a/src/entry.c b/src/entry.c
-index e9e258b..bb7cb62 100644
---- a/src/entry.c
-+++ b/src/entry.c
-@@ -595,6 +595,7 @@ get_range(bitstr_t * bits, int low, int high, const char *names[],
- return (EOF);
-
- case R_RANGE:
-+ unget_char(ch, file);
- if (get_number(&num2, low, names, file) != EOF) {
- state = R_RANGE_NUM2;
- break;