summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /sys-process/daemontools-encore
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'sys-process/daemontools-encore')
-rw-r--r--sys-process/daemontools-encore/Manifest1
-rw-r--r--sys-process/daemontools-encore/daemontools-encore-1.10.ebuild51
-rw-r--r--sys-process/daemontools-encore/files/svscan.init-229
-rw-r--r--sys-process/daemontools-encore/metadata.xml14
4 files changed, 95 insertions, 0 deletions
diff --git a/sys-process/daemontools-encore/Manifest b/sys-process/daemontools-encore/Manifest
new file mode 100644
index 000000000000..464c8a836d7e
--- /dev/null
+++ b/sys-process/daemontools-encore/Manifest
@@ -0,0 +1 @@
+DIST daemontools-encore-1.10.tar.gz 87096 SHA256 9f48f3c6cdd3f2b0202532e87f9ff46ea86777ca31ebda3a96bed618104bbd31 SHA512 569030fb9941186f167644740d0424987105b7a818d5a3cdb4e90ced5530a16938b7205141ca2f198f83362269f9cc28eb5acafe9cd7f985c8e56d307f706767 WHIRLPOOL d4ad3bebb8467dbfb5b9d8a40020c50822ca14cfb9ebc1ff44b3563a93e3083061f7b16a137a6c7df6898df6349ee380b6453c299ee098286924ba92b6b279ac
diff --git a/sys-process/daemontools-encore/daemontools-encore-1.10.ebuild b/sys-process/daemontools-encore/daemontools-encore-1.10.ebuild
new file mode 100644
index 000000000000..caee2a530797
--- /dev/null
+++ b/sys-process/daemontools-encore/daemontools-encore-1.10.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit flag-o-matic qmail
+
+DESCRIPTION="Collection of tools for managing UNIX services"
+HOMEPAGE="http://untroubled.org/daemontools-encore/"
+SRC_URI="http://untroubled.org/daemontools-encore/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="selinux static"
+
+DEPEND=""
+RDEPEND="selinux? ( sec-policy/selinux-daemontools )
+ !sys-process/daemontools
+ !app-doc/daemontools-man"
+
+src_compile() {
+ use static && append-ldflags -static
+ qmail_set_cc
+ emake
+}
+
+src_install() {
+ keepdir /service
+
+ echo ${D}/usr/bin >conf-bin
+ echo ${D}/usr/share/man >conf-man
+ dodir /usr/bin
+ dodir /usr/share/man
+ emake install
+
+ dodoc ChangeLog CHANGES CHANGES.djb README TODO
+
+ newinitd "${FILESDIR}"/svscan.init-2 svscan
+}
+
+pkg_postinst() {
+ einfo
+ einfo "You can run daemontools using the svscan init.d script,"
+ einfo "or you could run it through inittab."
+ einfo "To use inittab, emerge supervise-scripts and run:"
+ einfo "svscan-add-to-inittab"
+ einfo "Then you can hup init with the command telinit q"
+ einfo
+}
diff --git a/sys-process/daemontools-encore/files/svscan.init-2 b/sys-process/daemontools-encore/files/svscan.init-2
new file mode 100644
index 000000000000..6121f8ee56d1
--- /dev/null
+++ b/sys-process/daemontools-encore/files/svscan.init-2
@@ -0,0 +1,29 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+pidfile="/var/run/svscan.pid"
+command="/usr/bin/svscan"
+command_args="/service"
+command_background="true"
+
+depend() {
+ use net
+ before ntpd ntp-client spamd apache apache2
+}
+
+stop() {
+ ebegin "Stopping service scan"
+ start-stop-daemon --stop --exec ${command} \
+ --pidfile ${pidfile}
+ eend $?
+
+ ebegin "Stopping service scan services"
+ svc -dx /service/* 2>/dev/null
+ eend $?
+
+ ebegin "Stopping service scan logging"
+ svc -dx /service/*/log 2>/dev/null
+ eend $?
+}
diff --git a/sys-process/daemontools-encore/metadata.xml b/sys-process/daemontools-encore/metadata.xml
new file mode 100644
index 000000000000..c9faa952c09f
--- /dev/null
+++ b/sys-process/daemontools-encore/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>base-system</herd>
+<longdescription lang="en">
+daemontools-encore is a collection of tools for managing UNIX services.
+It is derived from the public-domain release of daemontools by
+D. J. Bernstein.
+
+daemontools-encore adds numerous enhancements above what daemontools
+could do while maintaining backwards compatibility with daemontools.
+See the CHANGES file for more details on what features have been added.
+</longdescription>
+</pkgmetadata>