summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-01-23 06:40:04 +0000
committerSam James <sam@gentoo.org>2023-01-23 06:40:04 +0000
commit218a743b15f2b637605a6201c0d78c0ad8b23a83 (patch)
tree7a78ea45393cacf6ebc742b401d3d768e2d3964f /sys-process/parallel
parentsys-devel/gcc: note about amd64/x86 & i686 for CET (diff)
downloadgentoo-218a743b15f2b637605a6201c0d78c0ad8b23a83.tar.gz
gentoo-218a743b15f2b637605a6201c0d78c0ad8b23a83.tar.bz2
gentoo-218a743b15f2b637605a6201c0d78c0ad8b23a83.zip
sys-process/parallel: add 20230122
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'sys-process/parallel')
-rw-r--r--sys-process/parallel/Manifest2
-rw-r--r--sys-process/parallel/parallel-20230122.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/sys-process/parallel/Manifest b/sys-process/parallel/Manifest
index 320cd06ded9c..8c7ba8bb2066 100644
--- a/sys-process/parallel/Manifest
+++ b/sys-process/parallel/Manifest
@@ -4,3 +4,5 @@ DIST parallel-20221122.tar.bz2 2415514 BLAKE2B 0bb85853f3dd84dc51a9382f7d7867352
DIST parallel-20221122.tar.bz2.sig 2080 BLAKE2B a75d39ae0cf64c7979d211fca2f2daf2fa9c724b8b15970a02e67f0321d4495b1d90639085a732467eaf2ded3035d628bf3743bb6dcaa1941ab53dc541d47801 SHA512 f9d6bdf9aa35def812a28752e6f8a8780e6aba574167098251148efe7e6426d21a616ddb94ebd8d61c31f722ccf15f6e028e4d7034f7f277c8514a16a5fc372d
DIST parallel-20221222.tar.bz2 2417694 BLAKE2B cfbbe104be248ff1d96495e821161eb76aabedb3cb002d002d6f92dba6130790f767918de7da8249ded694002d1a572f384656bccbb59e0c7f834d874721d79e SHA512 f5e67863a3287ef8836c65f53bc8759d47a17cb457d3a42fe7ffcdc3acda3b46224ce06a40d7ec46339768d95b7d06d5cdc790ad0f8a615fedc5416e14b7301f
DIST parallel-20221222.tar.bz2.sig 2080 BLAKE2B b8344b3d080c515f30e2b23a44a62364af0a3b29d3187ed31d71cfcb165280904c642c7059d9fc34a51e39c42b6a06d70b196de6540411f5453c363e3f79c507 SHA512 59e088340430ac688b54fa021a3d3db166b65682aeea57bbcf1879d9149ab132c6599917e115959ad36355582387ce76da2da9b1f42966b1864dffed08b47a5f
+DIST parallel-20230122.tar.bz2 2471639 BLAKE2B 7f9544d14f5424dfc2976720d2e35883dd25e9a8dd1dcecbcca67ddf27ae05fb2c7e7f3b9428f7c21b375289d6ffd7b7e27e9b12d217b54e8ba11807f40908ff SHA512 e224954af1bcb481c02c344b713e7f02da549d62efb0b8fbfcbb0e30697e18c9860af4bca83bff61d685b37943c4f69146bb1d06cce9a3684de16e764d22c7f9
+DIST parallel-20230122.tar.bz2.sig 2080 BLAKE2B 997e37b8e7b4d6feb067f9090a6cfa4db9e65b14cd9c37d1cac142077fefed9a69910102438bc4b136e78ef6a76a42cee5e2869be5373c8e6c3aa984435bb947 SHA512 ce70a6979a7d31db55a086c2b6f979aae99df62b9527928082f7e38a8c4890f64a84cb65b2e03486a2076e931d1de95041c2ae75c9e093500a49fc9b13161a1d
diff --git a/sys-process/parallel/parallel-20230122.ebuild b/sys-process/parallel/parallel-20230122.ebuild
new file mode 100644
index 000000000000..3ab936f28fdf
--- /dev/null
+++ b/sys-process/parallel/parallel-20230122.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/oletange.asc
+inherit verify-sig
+
+DESCRIPTION="A shell tool for executing jobs in parallel locally or on remote machines"
+HOMEPAGE="https://www.gnu.org/software/parallel/ https://git.savannah.gnu.org/cgit/parallel.git/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
+SRC_URI+=" verify-sig? ( mirror://gnu/${PN}/${P}.tar.bz2.sig )"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/Devel-Size
+ dev-perl/Text-CSV
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Temp
+ virtual/perl-IO
+"
+DEPEND="${RDEPEND}"
+BDEPEND="verify-sig? ( >=sec-keys/openpgp-keys-oletange-20210423 )"
+
+src_configure() {
+ econf --docdir="${EPREFIX}"/usr/share/doc/${PF}/html
+}