summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 12:23:19 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 12:53:18 +0100
commit3ee411f1324ad2b881555d1bec5f943f1a7f28a1 (patch)
tree6f41e60778fca61521342418fc05d60e95f9ae44 /sys-process
parentRename {sys-devel → llvm-core}/clang-common (diff)
downloadgentoo-3ee411f1324ad2b881555d1bec5f943f1a7f28a1.tar.gz
gentoo-3ee411f1324ad2b881555d1bec5f943f1a7f28a1.tar.bz2
gentoo-3ee411f1324ad2b881555d1bec5f943f1a7f28a1.zip
Move {sys-devel → llvm-core}/clang
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'sys-process')
-rw-r--r--sys-process/below/below-0.8.1-r1.ebuild2
-rw-r--r--sys-process/btop/btop-1.3.2.ebuild4
-rw-r--r--sys-process/btop/btop-1.4.0.ebuild4
3 files changed, 5 insertions, 5 deletions
diff --git a/sys-process/below/below-0.8.1-r1.ebuild b/sys-process/below/below-0.8.1-r1.ebuild
index 9adeeff32e98..88a0655e8410 100644
--- a/sys-process/below/below-0.8.1-r1.ebuild
+++ b/sys-process/below/below-0.8.1-r1.ebuild
@@ -313,7 +313,7 @@ SLOT="0"
KEYWORDS="amd64 ~ppc64"
BDEPEND="
- sys-devel/clang
+ llvm-core/clang
virtual/pkgconfig
"
RDEPEND="
diff --git a/sys-process/btop/btop-1.3.2.ebuild b/sys-process/btop/btop-1.3.2.ebuild
index 8c201df6ae0f..e9dc507a809b 100644
--- a/sys-process/btop/btop-1.3.2.ebuild
+++ b/sys-process/btop/btop-1.3.2.ebuild
@@ -19,10 +19,10 @@ pkg_setup() {
if [[ "${MERGE_TYPE}" != "binary" ]]; then
if tc-is-clang ; then
if [[ "$(clang-major-version)" -lt 16 ]]; then
- die "sys-process/btop requires >=sys-devel/clang-16.0.0 to build."
+ die "sys-process/btop requires >=llvm-core/clang-16.0.0 to build."
fi
elif ! tc-is-gcc ; then
- die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc or >=sys-devel/clang-16.0.0 instead."
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc or >=llvm-core/clang-16.0.0 instead."
fi
fi
}
diff --git a/sys-process/btop/btop-1.4.0.ebuild b/sys-process/btop/btop-1.4.0.ebuild
index 5b537494beaf..2385413d54d0 100644
--- a/sys-process/btop/btop-1.4.0.ebuild
+++ b/sys-process/btop/btop-1.4.0.ebuild
@@ -25,10 +25,10 @@ pkg_setup() {
if [[ "${MERGE_TYPE}" != "binary" ]]; then
if tc-is-clang ; then
if [[ "$(clang-major-version)" -lt 16 ]]; then
- die "sys-process/btop requires >=sys-devel/clang-16.0.0 to build."
+ die "sys-process/btop requires >=llvm-core/clang-16.0.0 to build."
fi
elif ! tc-is-gcc ; then
- die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc or >=sys-devel/clang-16.0.0 instead."
+ die "$(tc-getCXX) is not a supported compiler. Please use sys-devel/gcc or >=llvm-core/clang-16.0.0 instead."
fi
fi
}