summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorgy Yakovlev <gyakovlev@gentoo.org>2023-03-20 15:40:37 -0700
committerGeorgy Yakovlev <gyakovlev@gentoo.org>2023-03-20 15:40:37 -0700
commitab34e2d24b716bb3eb5e5bf8b4082ab73c8a184c (patch)
treea66c35ab57b094e8a2861df8d597c8427fdad4df /virtual/rust
parentdev-lang/rust-bin: add 1.68.0 (diff)
downloadgentoo-ab34e2d24b716bb3eb5e5bf8b4082ab73c8a184c.tar.gz
gentoo-ab34e2d24b716bb3eb5e5bf8b4082ab73c8a184c.tar.bz2
gentoo-ab34e2d24b716bb3eb5e5bf8b4082ab73c8a184c.zip
virtual/rust: add 1.68.0
Closes: https://bugs.gentoo.org/901737 Signed-off-by: Georgy Yakovlev <gyakovlev@gentoo.org>
Diffstat (limited to 'virtual/rust')
-rw-r--r--virtual/rust/rust-1.68.0.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/virtual/rust/rust-1.68.0.ebuild b/virtual/rust/rust-1.68.0.ebuild
new file mode 100644
index 000000000000..ae12ed9a2d0f
--- /dev/null
+++ b/virtual/rust/rust-1.68.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit multilib-build
+
+DESCRIPTION="Virtual for Rust language compiler"
+
+LICENSE=""
+
+# adjust when rust upstream bumps internal llvm
+# we do not allow multiple llvm versions in dev-lang/rust for
+# neither system nor bundled, so we just hardcode it here.
+SLOT="0/llvm-15"
+KEYWORDS="~amd64 ~arm ~arm64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="rustfmt"
+
+BDEPEND=""
+RDEPEND="|| (
+ ~dev-lang/rust-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+ ~dev-lang/rust-bin-${PV}[rustfmt?,${MULTILIB_USEDEP}]
+)"