summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-03-10 04:21:11 +0000
committerSam James <sam@gentoo.org>2021-03-10 04:21:11 +0000
commitad49fd833d609fe1a93dd7b47df70a88dddd03d4 (patch)
tree2658bf36b2ea86cabc346cd77b1c602da0d9b8d3 /www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild
parentdev-libs/unittest++: Stabilize 2.0.0-r2 sparc, #770706 (diff)
downloadgentoo-ad49fd833d609fe1a93dd7b47df70a88dddd03d4.tar.gz
gentoo-ad49fd833d609fe1a93dd7b47df70a88dddd03d4.tar.bz2
gentoo-ad49fd833d609fe1a93dd7b47df70a88dddd03d4.zip
www-apache/mod_fastcgi_handler: workaround depend.apache eclass issues
Bug: https://bugs.gentoo.org/616612 Closes: https://bugs.gentoo.org/653606 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild')
-rw-r--r--www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild b/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild
new file mode 100644
index 000000000000..140492bd2770
--- /dev/null
+++ b/www-apache/mod_fastcgi_handler/mod_fastcgi_handler-0.6-r2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit apache-module
+
+DESCRIPTION="A simple FastCGI handler module"
+HOMEPAGE="https://github.com/hollow/mod_fastcgi_handler"
+SRC_URI="https://github.com/hollow/mod_fastcgi_handler/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+APACHE2_MOD_CONF="20_${PN}"
+APACHE2_MOD_DEFINE="FASTCGI_HANDLER"
+
+APXS2_ARGS="-o ${PN}.so -c *.c"
+
+need_apache2
+
+src_install() {
+ # bug #653606
+ # but true cause seems to be bug #616612
+ APACHE_BASEDIR="/usr/$(get_libdir)/apache2"
+ APACHE_MODULESDIR="${APACHE_BASEDIR}/modules"
+ default
+}