summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2021-01-22 09:25:22 -0100
committerJorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>2021-01-22 09:25:22 -0100
commit37d4f56f02e7a569e707e6a147ff93fe1205d8c8 (patch)
treeeb513e42a67ba266084d1f6be85bc1969e8b82a0 /www-apps/drupal/drupal-7.78.ebuild
parentdev-python/xdoctest: Add python@ as co-maint (diff)
downloadgentoo-37d4f56f02e7a569e707e6a147ff93fe1205d8c8.tar.gz
gentoo-37d4f56f02e7a569e707e6a147ff93fe1205d8c8.tar.bz2
gentoo-37d4f56f02e7a569e707e6a147ff93fe1205d8c8.zip
www-apps/drupal: Security bump - SA-CORE-2021-001.
Add releases 7.78, 8.9.13, 9.0.11 and 9.1.3. Drop drupal-8.8 as it's now EoL and other vulnerable releases. Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Jorge Manuel B. S. Vicetto (jmbsvicetto) <jmbsvicetto@gentoo.org>
Diffstat (limited to 'www-apps/drupal/drupal-7.78.ebuild')
-rw-r--r--www-apps/drupal/drupal-7.78.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/www-apps/drupal/drupal-7.78.ebuild b/www-apps/drupal/drupal-7.78.ebuild
new file mode 100644
index 000000000000..4e6998d1e429
--- /dev/null
+++ b/www-apps/drupal/drupal-7.78.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="MAINTAINERS.txt LICENSE.txt INSTALL.txt CHANGELOG.txt INSTALL.mysql.txt INSTALL.pgsql.txt INSTALL.sqlite.txt UPGRADE.txt "
+ dodoc ${docs}
+ rm -f ${docs} INSTALL COPYRIGHT.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default
+ webapp_serverowned "${MY_HTDOCSDIR}"/sites/default/settings.php
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+}