summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorViorel Munteanu <ceamac@gentoo.org>2023-03-11 08:43:49 +0200
committerViorel Munteanu <ceamac@gentoo.org>2023-03-11 13:03:40 +0200
commitbaf469aea7189e0c6bae572b389867cdde9fd3b3 (patch)
treef5e13898c846b088f885ceaf9511d93a8b3c4a02 /www-apps/drupal
parentwww-apps/drupal: drop 8.9.20 (diff)
downloadgentoo-baf469aea7189e0c6bae572b389867cdde9fd3b3.tar.gz
gentoo-baf469aea7189e0c6bae572b389867cdde9fd3b3.tar.bz2
gentoo-baf469aea7189e0c6bae572b389867cdde9fd3b3.zip
www-apps/drupal: add 9.4.10
drupal 9.4.10 is the latest security release from 9.4 branch from 2023-01-18. drupal 9.1.x and 9.2.x reached end of life. Signed-off-by: Viorel Munteanu <ceamac@gentoo.org>
Diffstat (limited to 'www-apps/drupal')
-rw-r--r--www-apps/drupal/Manifest1
-rw-r--r--www-apps/drupal/drupal-9.4.10.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/www-apps/drupal/Manifest b/www-apps/drupal/Manifest
index e49a50dfa1b5..89f6f25fa61a 100644
--- a/www-apps/drupal/Manifest
+++ b/www-apps/drupal/Manifest
@@ -2,3 +2,4 @@ DIST drupal-7.89.tar.gz 3361853 BLAKE2B 5388c6c9ded2ce31caee1bea23976e2c2d53116f
DIST drupal-7.91.tar.gz 3369203 BLAKE2B 202b3cbcbb25bb92f056c15cb8f697038caacdd62497de02b7e0036dc5dd5ac6e9b12c67620b753a5fbe8440e5883aec3061a626d753d9cca4f48b6d6358b3fc SHA512 da38735563cf5a76f432907b61943339b9d7f218e5abe5b5187138a470b545db14e23bb708fa53adc0853f9b46b34242e7eae3222e53b62fdafef29b2b476169
DIST drupal-9.1.15.tar.gz 18580086 BLAKE2B 500602e498de55d2163c53d2cb04effbdab24d343a2f04262275c6500d9329b12760dee846513efbddc37916973dc9ad4bf0f6f882b1b57b0ca97b40afb369be SHA512 1fd8cbdbf0de00ed6d85a004f61fb3897cfcbc1f71d1d72373c8acf108f21774f3a91138901d9a3d0043f6b65b29ae7f953dfce1428a96a4fe529aac907141c0
DIST drupal-9.2.18.tar.gz 18882937 BLAKE2B 9e62b041c0d3cd634984fa29c72b35af9a1d9777d1b3c204fb55fd125d7270242177b30876a03e36aa3757b1445fd7763db82a2f038e7931d84df7f908150abb SHA512 ed91530280a6150070d4086a388084b6336526363fb56585c85e090f9e3fd1b3e90a82eb83b07a6c725eae3ba994228b5cf280d3c296650d9e2be9e97996aa31
+DIST drupal-9.4.10.tar.gz 21631038 BLAKE2B 635bca79c8ac0230205eb4eb11b4e790d49a3359c0fc1f535b936535b8541de71f0319806da221a9179b0b13c8f3d28ccf0f4d7c9088e459d9ff8274b3965b58 SHA512 befefe68ef0b6818ba9637fea2b007119483b431950cf0d81090d27b1e1672ab8c84be46ea1b083acf7dc4898bd4cfb294cd74a21cd5105cccef3d285c357739
diff --git a/www-apps/drupal/drupal-9.4.10.ebuild b/www-apps/drupal/drupal-9.4.10.ebuild
new file mode 100644
index 000000000000..cfe37862af18
--- /dev/null
+++ b/www-apps/drupal/drupal-9.4.10.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit webapp
+
+MY_PV=${PV:0:3}.0
+MY_P=${P/_/-}
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="PHP-based open-source platform and content management system"
+HOMEPAGE="https://www.drupal.org/"
+SRC_URI="https://ftp.drupal.org/files/projects/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres sqlite +uploadprogress"
+
+RDEPEND="
+ dev-lang/php[gd,hash(+),mysql?,pdo,postgres?,simplexml,sqlite?,xml]
+ virtual/httpd-php
+ uploadprogress? ( dev-php/pecl-uploadprogress )
+"
+
+need_httpd_cgi
+
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+src_install() {
+ webapp_src_preinst
+
+ local docs="LICENSE.txt README.md core/MAINTAINERS.txt core/INSTALL.txt core/CHANGELOG.txt \
+ core/INSTALL.mysql.txt core/INSTALL.pgsql.txt core/INSTALL.sqlite.txt core/UPDATE.txt "
+
+ dodoc ${docs}
+ rm ${docs} core/COPYRIGHT.txt core/LICENSE.txt || die
+
+ cp sites/default/{default.settings.php,settings.php} || die
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ dodir "${MY_HTDOCSDIR}"/files
+ webapp_serverowned "${MY_HTDOCSDIR}"/files
+
+ webapp_configfile "${MY_HTDOCSDIR}"/sites/default/settings.php
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_postinst_txt en "${FILESDIR}"/postinstall-en.txt
+
+ webapp_src_install
+}
+
+pkg_postinst() {
+ echo
+ ewarn "SECURITY NOTICE"
+ ewarn "If you plan on using SSL on your Drupal site, please consult the postinstall information:"
+ ewarn "\t# webapp-config --show-postinst ${PN} ${PV}"
+ echo
+ ewarn "If this is a new install, unless you want anyone with network access to your server to be"
+ ewarn "able to run the setup, you'll have to configure your web server to limit access to it."
+ echo
+ ewarn "If you're doing a new drupal-9 install, you'll have to copy /sites/default/default.services.yml"
+ ewarn "to /sites/default/services.yml and grant it write permissions to your web server."
+ ewarn "Just follow the instructions of the drupal setup and be sure to resolve any permissions issue"
+ ewarn "reported by the setup."
+ echo
+}