summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2020-06-10 13:49:43 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2020-06-10 13:58:40 +0200
commitfe6059f3f1c6ac220154c0ab36b6e88a46f3faa8 (patch)
treea610a256a8f40ce492698e0039e2c9e7a36350f4 /www-apps/nextcloud/nextcloud-17.0.7.ebuild
parentwww-apps/nextcloud: drop 16.0 versions (diff)
downloadgentoo-fe6059f3f1c6ac220154c0ab36b6e88a46f3faa8.tar.gz
gentoo-fe6059f3f1c6ac220154c0ab36b6e88a46f3faa8.tar.bz2
gentoo-fe6059f3f1c6ac220154c0ab36b6e88a46f3faa8.zip
www-apps/nextcloud: 18.0.6, 17.0.7 bumps
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps/nextcloud/nextcloud-17.0.7.ebuild')
-rw-r--r--www-apps/nextcloud/nextcloud-17.0.7.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/www-apps/nextcloud/nextcloud-17.0.7.ebuild b/www-apps/nextcloud/nextcloud-17.0.7.ebuild
new file mode 100644
index 000000000000..de1b7898efdf
--- /dev/null
+++ b/www-apps/nextcloud/nextcloud-17.0.7.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit webapp
+
+DESCRIPTION="Personal cloud that runs on your own server"
+HOMEPAGE="https://nextcloud.com/"
+SRC_URI="https://download.nextcloud.com/server/releases/${P}.tar.bz2"
+LICENSE="AGPL-3"
+
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="+curl +imagemagick mysql postgres +sqlite"
+REQUIRED_USE="|| ( mysql postgres sqlite )"
+
+DEPEND=""
+RDEPEND="dev-lang/php[curl?,filter,gd,hash(+),intl,json,mysql?,pdo,posix,postgres?,session,simplexml,sqlite?,truetype,xmlreader,xmlwriter,zip]
+ imagemagick? ( dev-php/pecl-imagick )
+ virtual/httpd-php"
+
+S=${WORKDIR}/${PN}
+
+pkg_setup() {
+ webapp_pkg_setup
+}
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+ dodir "${MY_HTDOCSDIR}"/data
+
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/apps
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/config
+ webapp_configfile "${MY_HTDOCSDIR}"/.htaccess
+
+ webapp_src_install
+}