summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2024-07-16 19:54:17 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2024-07-16 19:55:27 +0200
commite60a34136cfc0a1b508120c253d4953d763c00c9 (patch)
tree72145b2511c3348d193c33da2f354eceec5d61e5 /www-apps
parentdev-qt/qtwayland: backport yet another fix for plasma (diff)
downloadgentoo-e60a34136cfc0a1b508120c253d4953d763c00c9.tar.gz
gentoo-e60a34136cfc0a1b508120c253d4953d763c00c9.tar.bz2
gentoo-e60a34136cfc0a1b508120c253d4953d763c00c9.zip
www-apps/piwigo: add 14.5.0
Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'www-apps')
-rw-r--r--www-apps/piwigo/Manifest1
-rw-r--r--www-apps/piwigo/piwigo-14.5.0.ebuild42
2 files changed, 43 insertions, 0 deletions
diff --git a/www-apps/piwigo/Manifest b/www-apps/piwigo/Manifest
index 437f95863f78..f51b80f264ca 100644
--- a/www-apps/piwigo/Manifest
+++ b/www-apps/piwigo/Manifest
@@ -1,2 +1,3 @@
DIST piwigo-14.3.0.zip 18497258 BLAKE2B 1ba04c81298c3de9edc3dd4f2c10feed9bb320ad0ed80fbc8edb36a8c590025b580684c4ce9cb0283d5b9580e32c44fe5673214a926e98335a3c69a18051a4c1 SHA512 80c34c150dc55f312c3ce4a694cae559e529375d657ce47c05c8650bbb452577f6ab6f41816ef37de5a34fc1d31bf152962fe20741403991d347bf2245dcd91c
DIST piwigo-14.4.0.zip 18500565 BLAKE2B c62dc0c5bfaae89d56cdc51aeef04d7e75dc25cd400918ac879f227e2f03028d5e4b556d8a3a79a2ae587b45b13cf7d192912a35c4cbc8029743eede20a07bd2 SHA512 2aecba41df2f39a864f58775cadecc8812647390c9b5cc0acfe67767de6130bc8166d65d76c8e59437494d52a4560554a94f8ba7beab44a9fb38997db430417e
+DIST piwigo-14.5.0.zip 18502471 BLAKE2B 2e7dbbdb4cd9505feb93435c6c81b9a0d352c9547eaebb91b233c45e38f21dedef26b4f84d5d8ab762948c9949b05c6f526c6bf6ea381ab9c6fb6f5b024dcb26 SHA512 5736bdb737d88ab217c641c6a076ece80f81307cf26bfbee2204327ceacf918977b60bd094867a988ebeaa14d017334ff45d1b2c0612757f5dad1dccc572f5e6
diff --git a/www-apps/piwigo/piwigo-14.5.0.ebuild b/www-apps/piwigo/piwigo-14.5.0.ebuild
new file mode 100644
index 000000000000..6319946ac014
--- /dev/null
+++ b/www-apps/piwigo/piwigo-14.5.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+inherit webapp
+
+DESCRIPTION="a photo gallery software for the web"
+HOMEPAGE="http://piwigo.org/"
+SRC_URI="http://piwigo.org/download/dlcounter.php?code=${PV} -> ${P}.zip"
+S=${WORKDIR}/${PN}
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+exif +gd imagemagick"
+
+RDEPEND="
+ imagemagick? ( virtual/imagemagick-tools )
+ dev-lang/php[ctype,exif?,gd?,filter,iconv,json(+),mysqli]
+ >=virtual/mysql-5.0
+ virtual/httpd-php"
+BDEPEND="app-arch/unzip"
+
+REQUIRED_USE="|| ( gd imagemagick )"
+
+src_install() {
+ webapp_src_preinst
+
+ insinto "${MY_HTDOCSDIR}"
+ doins -r .
+
+ # Local configuration, and parts that can be updated
+ webapp_serverowned "${MY_HTDOCSDIR}"/_data
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/galleries
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/language
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/local
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/plugins
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/template-extension
+ webapp_serverowned -R "${MY_HTDOCSDIR}"/themes
+ webapp_serverowned "${MY_HTDOCSDIR}"/upload
+
+ webapp_src_install
+}