summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2023-01-17 16:20:44 +0200
committerJoonas Niilola <juippis@gentoo.org>2023-01-17 16:20:44 +0200
commit83c5840a3b8cd1ef63196aa13bef45df7c6149e7 (patch)
tree7c61706fab48cb1378c1a8e421c967a0fda021a0 /www-client/firefox/firefox-109.0.ebuild
parentmedia-fonts/lxgw-wenkai: add 1.250 (diff)
downloadgentoo-83c5840a3b8cd1ef63196aa13bef45df7c6149e7.tar.gz
gentoo-83c5840a3b8cd1ef63196aa13bef45df7c6149e7.tar.bz2
gentoo-83c5840a3b8cd1ef63196aa13bef45df7c6149e7.zip
www-client/firefox: update patch set for 109.0
- move configure option for real-time-tracing under 'debug' use flag, - remove moz_clear_vendor_checksums call - unneeded as of 109, - remove one extra useless .swp file from the patch set. Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'www-client/firefox/firefox-109.0.ebuild')
-rw-r--r--www-client/firefox/firefox-109.0.ebuild9
1 files changed, 4 insertions, 5 deletions
diff --git a/www-client/firefox/firefox-109.0.ebuild b/www-client/firefox/firefox-109.0.ebuild
index 1243ab1925e5..62bacfdb5569 100644
--- a/www-client/firefox/firefox-109.0.ebuild
+++ b/www-client/firefox/firefox-109.0.ebuild
@@ -3,7 +3,7 @@
EAPI=8
-FIREFOX_PATCHSET="firefox-109-patches-01j.tar.xz"
+FIREFOX_PATCHSET="firefox-109-patches-02j.tar.xz"
LLVM_MAX_SLOT=15
@@ -646,9 +646,6 @@ src_prepare() {
einfo "Removing pre-built binaries ..."
find "${S}"/third_party -type f \( -name '*.so' -o -name '*.o' \) -print -delete || die
- # Clearing crate checksums where we have applied patches
- moz_clear_vendor_checksums bindgen
-
# Create build dir
BUILD_DIR="${WORKDIR}/${PN}_build"
mkdir -p "${BUILD_DIR}" || die
@@ -736,7 +733,6 @@ src_configure() {
--disable-gpsd \
--disable-install-strip \
--disable-parental-controls \
- --disable-real-time-tracing \
--disable-strip \
--disable-tests \
--disable-updater \
@@ -894,7 +890,10 @@ src_configure() {
mozconfig_use_enable debug
if use debug ; then
mozconfig_add_options_ac '+debug' --disable-optimize
+ mozconfig_add_options_ac '+debug' --enable-real-time-tracing
else
+ mozconfig_add_options_ac 'Gentoo defaults' --disable-real-time-tracing
+
if is-flag '-g*' ; then
if use clang ; then
mozconfig_add_options_ac 'from CFLAGS' --enable-debug-symbols=$(get-flag '-g*')