summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2020-03-30 15:47:01 +0200
committerThomas Deutschmann <whissi@gentoo.org>2020-03-30 15:47:27 +0200
commit01c322d14b9adaafc8711b73010f0a2f9a9b9916 (patch)
treebd4b1d6590ed38f93f13a483799f592e4d24a20d /www-client
parentapp-emacs/eselect-mode: x86 stable wrt bug #715300 (diff)
downloadgentoo-01c322d14b9adaafc8711b73010f0a2f9a9b9916.tar.gz
gentoo-01c322d14b9adaafc8711b73010f0a2f9a9b9916.tar.bz2
gentoo-01c322d14b9adaafc8711b73010f0a2f9a9b9916.zip
www-client/firefox: really disable Normandy service
...while there, also disable DoH which we already disabled in normal Firefox. Fixes 23e30a18c ("www-client/firefox: disable Normandy service by default") Bug: https://bugs.gentoo.org/713782 Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/firefox/files/gentoo-default-prefs.js-217
-rw-r--r--www-client/firefox/firefox-68.6.0-r3.ebuild (renamed from www-client/firefox/firefox-68.6.0-r2.ebuild)25
2 files changed, 20 insertions, 22 deletions
diff --git a/www-client/firefox/files/gentoo-default-prefs.js-2 b/www-client/firefox/files/gentoo-default-prefs.js-2
deleted file mode 100644
index ffd0d7dc8ee7..000000000000
--- a/www-client/firefox/files/gentoo-default-prefs.js-2
+++ /dev/null
@@ -1,17 +0,0 @@
-pref("app.update.enabled", false);
-pref("app.update.autoInstallEnabled", false);
-pref("browser.display.use_system_colors", true);
-pref("browser.link.open_external", 3);
-pref("general.smoothScroll", true);
-pref("general.autoScroll", false);
-pref("browser.tabs.tabMinWidth", 15);
-pref("browser.backspace_action", 0);
-pref("browser.urlbar.hideGoButton", true);
-pref("accessibility.typeaheadfind", true);
-pref("browser.shell.checkDefaultBrowser", false);
-pref("browser.EULA.override", true);
-pref("general.useragent.vendor", "Gentoo");
-pref("general.useragent.locale", "chrome://global/locale/intl.properties");
-pref("intl.locale.requested", "");
-pref("extensions.autoDisableScopes", 0);
-pref("layout.css.dpi", 0);
diff --git a/www-client/firefox/firefox-68.6.0-r2.ebuild b/www-client/firefox/firefox-68.6.0-r3.ebuild
index a10f2faf8a77..24ceeba5ece5 100644
--- a/www-client/firefox/firefox-68.6.0-r2.ebuild
+++ b/www-client/firefox/firefox-68.6.0-r3.ebuild
@@ -641,7 +641,7 @@ src_install() {
pax-mark m "${BUILD_OBJ_DIR}"/dist/bin/xpcshell
# Add our default prefs for firefox
- cp "${FILESDIR}"/gentoo-default-prefs.js-2 \
+ cp "${FILESDIR}"/gentoo-default-prefs.js-3 \
"${BUILD_OBJ_DIR}/dist/bin/browser/defaults/preferences/all-gentoo.js" \
|| die
@@ -852,22 +852,37 @@ pkg_postinst() {
elog
fi
- local show_normandy_information
+ local show_doh_information show_normandy_information
if [[ -z "${REPLACING_VERSIONS}" ]] ; then
- # New install
+ # New install; Tell user that DoH is disabled by default
+ show_doh_information=yes
show_normandy_information=yes
else
local replacing_version
for replacing_version in ${REPLACING_VERSIONS} ; do
- if ver_test "${replacing_version}" -lt 68.6.0-r2 ; then
+ if ver_test "${replacing_version}" -lt 68.6.0-r3 ; then
+ # Tell user only once about our DoH default
+ show_doh_information=yes
+ fi
+
+ if ver_test "${replacing_version}" -lt 68.6.0-r3 ; then
# Tell user only once about our Normandy default
show_normandy_information=yes
- break
fi
done
fi
+ if [[ -n "${show_doh_information}" ]] ; then
+ elog
+ elog "Note regarding Trusted Recursive Resolver aka DNS-over-HTTPS (DoH):"
+ elog "Due to privacy concerns (encrypting DNS might be a good thing, sending all"
+ elog "DNS traffic to Cloudflare by default is not a good idea and applications"
+ elog "should respect OS configured settings), \"network.trr.mode\" was set to 5"
+ elog "(\"Off by choice\") by default."
+ elog "You can enable DNS-over-HTTPS in ${PN^}'s preferences."
+ fi
+
# bug 713782
if [[ -n "${show_normandy_information}" ]] ; then
elog