summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2022-11-29 02:17:17 +0100
committerSebastian Pipping <sping@gentoo.org>2022-11-29 02:17:17 +0100
commit60310bff700efe979b3303e7ff3627d2c3abf287 (patch)
tree00ca6c23f70c00a27c37359bd5c57df6382cd02b /www-client
parentsys-apps/usbguard: MissingRemoteId (diff)
downloadgentoo-60310bff700efe979b3303e7ff3627d2c3abf287.tar.gz
gentoo-60310bff700efe979b3303e7ff3627d2c3abf287.tar.bz2
gentoo-60310bff700efe979b3303e7ff3627d2c3abf287.zip
www-client/httrack: EAPI 8 + UnusedInherits
Signed-off-by: Sebastian Pipping <sping@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/httrack/httrack-3.49.2-r3.ebuild70
1 files changed, 70 insertions, 0 deletions
diff --git a/www-client/httrack/httrack-3.49.2-r3.ebuild b/www-client/httrack/httrack-3.49.2-r3.ebuild
new file mode 100644
index 000000000000..b306e0d666ba
--- /dev/null
+++ b/www-client/httrack/httrack-3.49.2-r3.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit autotools xdg-utils
+
+DESCRIPTION="HTTrack Website Copier, Open Source Offline Browser"
+HOMEPAGE="https://www.httrack.com/"
+SRC_URI="https://mirror.httrack.com/historical/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux"
+IUSE="static-libs"
+
+RDEPEND=">=sys-libs/zlib-1.2.5.1-r1
+ >=dev-libs/openssl-1.1.0:=
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( AUTHORS README greetings.txt history.txt )
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.48.13-minizip.patch
+)
+
+src_prepare() {
+ default
+
+ # We need to patch use of /usr/lib because it is a problem with
+ # linker lld with profile 17.1 on amd64 (see https://bugs.gentoo.org/732272).
+ # The grep sandwich acts as a regression test so that a future
+ # version bump cannot break patching without noticing.
+ if [[ "$(get_libdir)" != lib ]]; then
+ grep -wq '{ZLIB_HOME}/lib' m4/check_zlib.m4 || die
+ sed "s,{ZLIB_HOME}/lib,{ZLIB_HOME}/$(get_libdir)," -i m4/check_zlib.m4 || die
+ grep -w '{ZLIB_HOME}/lib' m4/check_zlib.m4 && die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ # Make webhttrack work despite FEATURES=nodoc cutting
+ # all of /usr/share/doc/ away (bug #493376)
+ if has nodoc ${FEATURES} ; then
+ dodir /usr/share/${PF}/
+ mv "${D}"/usr/share/{doc/,}${PF}/html || die
+
+ rm "${D}"/usr/share/${PN}/html || die
+ dosym ../../${PF}/html /usr/share/${PN}/html
+ fi
+
+ find "${D}" -name '*.la' -type f -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}