summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-01-14 06:55:38 -0500
committerIonen Wolkens <ionen@gentoo.org>2023-01-14 07:04:25 -0500
commitdce3bd4fb7077a89de90e6d16b5c24ac58af71d7 (patch)
tree7e6af26f03430cba6fe7cb30c870b96daf6c8b68 /www-client
parentdev-util/rbtools: Stabilize 4.0-r1 x86, #890798 (diff)
downloadgentoo-dce3bd4fb7077a89de90e6d16b5c24ac58af71d7.tar.gz
gentoo-dce3bd4fb7077a89de90e6d16b5c24ac58af71d7.tar.bz2
gentoo-dce3bd4fb7077a89de90e6d16b5c24ac58af71d7.zip
www-client/qutebrowser: cleanup py3.8 and importlib_resources dep
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'www-client')
-rw-r--r--www-client/qutebrowser/qutebrowser-2.5.2-r1.ebuild5
-rw-r--r--www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild6
-rw-r--r--www-client/qutebrowser/qutebrowser-9999.ebuild5
3 files changed, 6 insertions, 10 deletions
diff --git a/www-client/qutebrowser/qutebrowser-2.5.2-r1.ebuild b/www-client/qutebrowser/qutebrowser-2.5.2-r1.ebuild
index 459d498416d1..1e0b94274b51 100644
--- a/www-client/qutebrowser/qutebrowser-2.5.2-r1.ebuild
+++ b/www-client/qutebrowser/qutebrowser-2.5.2-r1.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 xdg
if [[ ${PV} == 9999 ]]; then
@@ -26,7 +26,6 @@ IUSE="+adblock pdf widevine"
RDEPEND="
dev-qt/qtcore:5[icu]
dev-qt/qtgui:5[png]
- $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' 3.8)
$(python_gen_cond_dep '
dev-python/colorama[${PYTHON_USEDEP}]
>=dev-python/jinja-3.0.2[${PYTHON_USEDEP}]
diff --git a/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild b/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild
index 08fc978ae6f4..5fa6c903ac8c 100644
--- a/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-3.0.0_pre9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 multiprocessing xdg
if [[ ${PV} == *9999 ]]; then
@@ -26,8 +26,6 @@ IUSE="+adblock pdf +qt6 widevine"
RDEPEND="
$(python_gen_cond_dep '
- dev-python/importlib_resources[${PYTHON_USEDEP}]' 3.8)
- $(python_gen_cond_dep '
dev-python/colorama[${PYTHON_USEDEP}]
>=dev-python/jinja-3.1.2[${PYTHON_USEDEP}]
>=dev-python/markupsafe-2.1.1[${PYTHON_USEDEP}]
diff --git a/www-client/qutebrowser/qutebrowser-9999.ebuild b/www-client/qutebrowser/qutebrowser-9999.ebuild
index c4bb985b2edc..3d0c12b40655 100644
--- a/www-client/qutebrowser/qutebrowser-9999.ebuild
+++ b/www-client/qutebrowser/qutebrowser-9999.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_SINGLE_IMPL=1
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
+PYTHON_COMPAT=( python3_{9..11} )
inherit distutils-r1 xdg
if [[ ${PV} == 9999 ]]; then
@@ -26,7 +26,6 @@ IUSE="+adblock pdf widevine"
RDEPEND="
dev-qt/qtcore:5[icu]
dev-qt/qtgui:5[png]
- $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' 3.8)
$(python_gen_cond_dep '
dev-python/colorama[${PYTHON_USEDEP}]
>=dev-python/jinja-3.0.2[${PYTHON_USEDEP}]