summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /www-plugins/kpartsplugin
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'www-plugins/kpartsplugin')
-rw-r--r--www-plugins/kpartsplugin/Manifest1
-rw-r--r--www-plugins/kpartsplugin/files/kpartsplugin-20120723-segfault.patch21
-rw-r--r--www-plugins/kpartsplugin/kpartsplugin-20120723-r1.ebuild22
-rw-r--r--www-plugins/kpartsplugin/kpartsplugin-20120723-r2.ebuild24
-rw-r--r--www-plugins/kpartsplugin/metadata.xml5
5 files changed, 73 insertions, 0 deletions
diff --git a/www-plugins/kpartsplugin/Manifest b/www-plugins/kpartsplugin/Manifest
new file mode 100644
index 000000000000..0c367f187b50
--- /dev/null
+++ b/www-plugins/kpartsplugin/Manifest
@@ -0,0 +1 @@
+DIST kpartsplugin-20120723.tar.bz2 34786 SHA256 dfdc7a9c810ce380e742b1911dce8b2f59136c6a17b0b1ca13d6f6c190c7f851 SHA512 49896ca4569368c35c8b82e1882c7f4e98ccbc8f2726cfa9cdb9cd5d839732a87de7f2d087f77ed0d91b0832747e64392af92a1bee2462c8aa086990c60163ba WHIRLPOOL 6ec7519264a34e221a5685b2694cb9c0a4dd82b18d0f4fa46a381bd6dc4b6c0bb3d25ef7fae30b700c8389e57073ad4b13978b5fb8c0dd78115aba982da8481e
diff --git a/www-plugins/kpartsplugin/files/kpartsplugin-20120723-segfault.patch b/www-plugins/kpartsplugin/files/kpartsplugin-20120723-segfault.patch
new file mode 100644
index 000000000000..9ac0aeef0d2a
--- /dev/null
+++ b/www-plugins/kpartsplugin/files/kpartsplugin-20120723-segfault.patch
@@ -0,0 +1,21 @@
+commit e883f236c476830fec2306b6b4ad90ec27f643a1
+Author: Mario Kicherer <kicherer@kit.edu>
+Date: Fri Jun 26 11:34:21 2015 +0200
+
+ fix crash after kpart selection dialog
+
+diff --git a/src/kpartsplugin.cpp b/src/kpartsplugin.cpp
+index a9ee9df..56c4aa4 100644
+--- a/src/kpartsplugin.cpp
++++ b/src/kpartsplugin.cpp
+@@ -120,8 +120,8 @@ public:
+ dlg.exec();
+ rememberChoice = dlg.checkBoxRemember->checkState() == Qt::Checked;
+ /// fetch first (and only) selected item in list
+- QList<QListWidgetItem *>::ConstIterator it(dlg.listWidget->selectedItems().constBegin());
+- return (*it)->text();
++ QList<QListWidgetItem *> it(dlg.listWidget->selectedItems());
++ return it.at(0)->text();
+ }
+
+ };
diff --git a/www-plugins/kpartsplugin/kpartsplugin-20120723-r1.ebuild b/www-plugins/kpartsplugin/kpartsplugin-20120723-r1.ebuild
new file mode 100644
index 000000000000..7651db27a2dc
--- /dev/null
+++ b/www-plugins/kpartsplugin/kpartsplugin-20120723-r1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base nsplugins
+
+DESCRIPTION="Plugin using KDE's KParts technology to embed file viewers into non-KDE browsers"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~fischer/kpartsplugin/"
+SRC_URI="http://www.unix-ag.uni-kl.de/~fischer/kpartsplugin/${P}.tar.bz2"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+
+IUSE="debug"
+
+src_prepare() {
+ echo "set( PLUGIN_INSTALL_DIR \"/usr/$(get_libdir)/${PLUGINS_DIR}/\" )" >> CMakeLists.txt || die
+ kde4-base_src_prepare
+}
diff --git a/www-plugins/kpartsplugin/kpartsplugin-20120723-r2.ebuild b/www-plugins/kpartsplugin/kpartsplugin-20120723-r2.ebuild
new file mode 100644
index 000000000000..c847c777f47a
--- /dev/null
+++ b/www-plugins/kpartsplugin/kpartsplugin-20120723-r2.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit kde4-base nsplugins
+
+DESCRIPTION="Plugin using KDE's KParts technology to embed file viewers into non-KDE browsers"
+HOMEPAGE="http://www.unix-ag.uni-kl.de/~fischer/kpartsplugin/"
+SRC_URI="http://www.unix-ag.uni-kl.de/~fischer/kpartsplugin/${P}.tar.bz2"
+
+LICENSE="GPL-3 BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug"
+
+PATCHES=( "${FILESDIR}/${P}-segfault.patch" )
+
+src_prepare() {
+ echo "set( PLUGIN_INSTALL_DIR \"/usr/$(get_libdir)/${PLUGINS_DIR}/\" )" >> CMakeLists.txt || die
+ kde4-base_src_prepare
+}
diff --git a/www-plugins/kpartsplugin/metadata.xml b/www-plugins/kpartsplugin/metadata.xml
new file mode 100644
index 000000000000..8d1e86a9cefb
--- /dev/null
+++ b/www-plugins/kpartsplugin/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>kde</herd>
+</pkgmetadata>