summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2021-09-13 14:21:46 -0400
committerMike Pagano <mpagano@gentoo.org>2021-09-13 14:21:46 -0400
commit69589f3c571a1c6e934824403b281cc8c5d0d2ca (patch)
treeaa68ec568188a0d0d2253a97ee5cc97cb0d63a75 /www-servers/nginx-unit/nginx-unit-1.25.0.ebuild
parentdev-python/jupyter_console: Fix DISTUTILS_USE_SETUPTOOLS (diff)
downloadgentoo-69589f3c571a1c6e934824403b281cc8c5d0d2ca.tar.gz
gentoo-69589f3c571a1c6e934824403b281cc8c5d0d2ca.tar.bz2
gentoo-69589f3c571a1c6e934824403b281cc8c5d0d2ca.zip
www-servers/nginx-unit: Patch for glibc 2.34 support
Closes: https://bugs.gentoo.org/812467 Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Mike Pagano <mpagano@gentoo.org>
Diffstat (limited to 'www-servers/nginx-unit/nginx-unit-1.25.0.ebuild')
-rw-r--r--www-servers/nginx-unit/nginx-unit-1.25.0.ebuild6
1 files changed, 5 insertions, 1 deletions
diff --git a/www-servers/nginx-unit/nginx-unit-1.25.0.ebuild b/www-servers/nginx-unit/nginx-unit-1.25.0.ebuild
index 5a6de36e3bf1..b4fa47193ab9 100644
--- a/www-servers/nginx-unit/nginx-unit-1.25.0.ebuild
+++ b/www-servers/nginx-unit/nginx-unit-1.25.0.ebuild
@@ -30,9 +30,12 @@ DEPEND="perl? ( dev-lang/perl:= )
dev-lang/ruby:*
dev-ruby/rubygems:*
)
- ssl? ( dev-libs/openssl:0= )"
+ ssl? ( dev-libs/openssl:0= )
+ virtual/libcrypt:0="
RDEPEND="${DEPEND}"
+PATCHES=( "${FILESDIR}"/${P}-glibc-2.34.patch )
+
pkg_setup() {
use python && python-single-r1_pkg_setup
}
@@ -40,6 +43,7 @@ pkg_setup() {
src_prepare() {
eapply_user
sed -i '/^CFLAGS/d' auto/make || die
+ default
}
src_configure() {