summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2024-08-12 12:23:57 -0400
committerMatt Turner <mattst88@gentoo.org>2024-08-12 12:25:41 -0400
commit0ed93269ee32c6215938233b93b3531fee81e640 (patch)
tree6350106cd5d2a8afb4f7047d2b068db9c56386fb /x11-base/xwayland
parentdev-libs/libei: Version bump to 1.3.0 (diff)
downloadgentoo-0ed93269ee32c6215938233b93b3531fee81e640.tar.gz
gentoo-0ed93269ee32c6215938233b93b3531fee81e640.tar.bz2
gentoo-0ed93269ee32c6215938233b93b3531fee81e640.zip
x11-base/xwayland: Version bump to 24.1.2
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-base/xwayland')
-rw-r--r--x11-base/xwayland/Manifest1
-rw-r--r--x11-base/xwayland/xwayland-24.1.2.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/x11-base/xwayland/Manifest b/x11-base/xwayland/Manifest
index 89ed5af379d0..839726b74b3c 100644
--- a/x11-base/xwayland/Manifest
+++ b/x11-base/xwayland/Manifest
@@ -1,3 +1,4 @@
DIST xwayland-23.2.6.tar.xz 1300092 BLAKE2B 5b10984a2c2fba87ce1101b70c26070100e743239dc705716c4b7e1318e192ad1da5e4933516f87ab0405b98eb1cc093081d4a1e4754f5dc8947a546a6f89072 SHA512 9e3c2253af335a559d0f890fa8f9bc381beca6531e0842d739ac15cbca008b3d07c0eefafd03611b04917c626861a7871a83657afa2a298994f4b162f714fc49
DIST xwayland-24.1.0.tar.xz 1301180 BLAKE2B d20f91fa6c1d404cafb69a7e1cf843458be084a5e0d4feb5266e6bc78a6ee0445aeb178e97c569eb17d13a8a3cc566ac664afcec02e1b56c92f9ea0b95be85b5 SHA512 7592609ad112652cb870761f938f280802d7d3b4bbc82acc7bf741a763d862aa97bbbd7f78250c63a961d76be73fb55555832045514092d89e406839564f0003
DIST xwayland-24.1.1.tar.xz 1301652 BLAKE2B 0b25776d7b6910b5a122d5ab917506ce933c87b6f0abf908649461f013463001161d1fa5fcaa499c56cfce57f035ad95fd49e28bb3e84ce159eaaad74b5b2799 SHA512 e44f47adab3830846360fd05fdc06d9016832133c662f2e4b0763b98de0c9b48dbfce7d757ffea5538b5fabb68170e5d1057acc1b9a086e396b147deaa750998
+DIST xwayland-24.1.2.tar.xz 1302068 BLAKE2B 761cc7da4e73da8120d5006ba085808e2c383fa991e29d3948c610671a11fee16295584d59409417ebb216fc8ae23de26d69eda7e453725067229672911ae85e SHA512 2788f6954c999c29be54d5b1e6e2c81327de9fbefae140f7cd322c1ff21f76fdd17cb74cf8243035ea850bfa4573d2013ab895426790b7959cceb7120ba9531c
diff --git a/x11-base/xwayland/xwayland-24.1.2.ebuild b/x11-base/xwayland/xwayland-24.1.2.ebuild
new file mode 100644
index 000000000000..3b5d437dd588
--- /dev/null
+++ b/x11-base/xwayland/xwayland-24.1.2.ebuild
@@ -0,0 +1,133 @@
+# Copyright 2021-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xorg/xserver.git"
+ inherit git-r3
+else
+ SRC_URI="https://xorg.freedesktop.org/archive/individual/xserver/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+DESCRIPTION="Standalone X server running under Wayland"
+HOMEPAGE="https://wayland.freedesktop.org/xserver.html"
+
+LICENSE="MIT"
+SLOT="0"
+
+IUSE="libei selinux systemd test unwind xcsecurity"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-libs/libbsd
+ dev-libs/openssl:=
+ >=dev-libs/wayland-1.21.0
+ >=dev-libs/wayland-protocols-1.34
+ media-fonts/font-util
+ >=media-libs/libepoxy-1.5.4[X,egl(+)]
+ media-libs/libglvnd[X]
+ >=media-libs/mesa-21.1[X(+),egl(+),gbm(+)]
+ >=x11-libs/libdrm-2.4.116
+ >=x11-libs/libXau-1.0.4
+ x11-libs/libxcvt
+ >=x11-libs/libXdmcp-1.0.2
+ >=x11-libs/libXfont2-2.0.1
+ x11-libs/libxkbfile
+ >=x11-libs/libxshmfence-1.1
+ >=x11-libs/pixman-0.27.2
+ >=x11-misc/xkeyboard-config-2.4.1-r3
+
+ libei? ( dev-libs/libei )
+ systemd? ( sys-apps/systemd )
+ unwind? ( sys-libs/libunwind )
+"
+DEPEND="
+ ${COMMON_DEPEND}
+ >=x11-base/xorg-proto-2024.1
+ >=x11-libs/xtrans-1.3.5
+ test? (
+ x11-misc/rendercheck
+ x11-libs/libX11
+ )
+"
+RDEPEND="
+ ${COMMON_DEPEND}
+ x11-apps/xkbcomp
+
+ libei? ( >=sys-apps/xdg-desktop-portal-1.18.0 )
+ selinux? ( sec-policy/selinux-xserver )
+"
+BDEPEND="
+ app-alternatives/lex
+ dev-util/wayland-scanner
+"
+
+src_prepare() {
+ default
+
+ if ! use test; then
+ sed -i -e "s/dependency('x11')/disabler()/" meson.build || die
+ fi
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use selinux xselinux)
+ $(meson_use systemd systemd_notify)
+ $(meson_use unwind libunwind)
+ $(meson_use xcsecurity)
+ -Ddpms=true
+ -Ddri3=true
+ -Ddrm=true
+ -Ddtrace=false
+ -Dglamor=true
+ -Dglx=true
+ -Dipv6=true
+ -Dsecure-rpc=false
+ -Dscreensaver=true
+ -Dsha1=libcrypto
+ -Dxace=true
+ -Dxdmcp=true
+ -Dxinerama=true
+ -Dxvfb=true
+ -Dxv=true
+ -Dxwayland-path="${EPREFIX}"/usr/bin
+ -Dlibdecor=false
+ -Ddocs=false
+ -Ddevel-docs=false
+ -Ddocs-pdf=false
+ )
+
+ if [[ ${PV} == "9999" ]]; then
+ emesonargs+=(
+ -Dxorg=false
+ -Dxnest=false
+ -Dxvfb=false
+ -Dxwayland=true
+ )
+ fi
+
+ if use libei; then
+ emesonargs+=( -Dxwayland_ei=portal )
+ else
+ emesonargs+=( -Dxwayland_ei=false )
+ fi
+
+ meson_src_configure
+}
+
+src_install() {
+ dosym ../bin/Xwayland /usr/libexec/Xwayland
+
+ meson_src_install
+
+ # Remove files installed by x11-base/xorg-xserver
+ rm \
+ "${ED}"/usr/share/man/man1/Xserver.1 \
+ "${ED}"/usr/$(get_libdir)/xorg/protocol.txt \
+ || die
+}