summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-09-02 03:25:56 +0200
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2015-09-02 03:25:56 +0200
commitb53f89fb0f2921c136fcba534591ba2007747900 (patch)
treede43981eb298ae8f8d6fd59e1a4b52e743be1af6 /x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
parentmedia-libs/mesa: radeonsi requires x11-libs/libdrm[video_cards_amdgpu] (diff)
downloadgentoo-b53f89fb0f2921c136fcba534591ba2007747900.tar.gz
gentoo-b53f89fb0f2921c136fcba534591ba2007747900.tar.bz2
gentoo-b53f89fb0f2921c136fcba534591ba2007747900.zip
x11-drivers/xf86-video-amdgpu: initial commit
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild')
-rw-r--r--x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
new file mode 100644
index 000000000000..7266714f6fe8
--- /dev/null
+++ b/x11-drivers/xf86-video-amdgpu/xf86-video-amdgpu-9999.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+XORG_DRI="always"
+XORG_EAUTORECONF=yes
+inherit xorg-2
+
+if [[ ${PV} == 9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="mirror://gentoo/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="Accelerated Open Source driver for AMDGPU cards"
+
+IUSE="glamor"
+
+RDEPEND="x11-libs/libdrm[video_cards_amdgpu]
+ x11-base/xorg-server[glamor(-)?]"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ XORG_CONFIGURE_OPTIONS="$(use_enable glamor)"
+ xorg-2_src_configure
+}