summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-06-05 10:35:39 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-06-05 10:36:20 -0400
commit3228548f74cc3faa12e0415733eadebace926fc2 (patch)
tree29c4ebacaf5772a1b7f3920e62e63609b34b5d3b /x11-drivers
parentdev-ruby/facter: drop 4.3.0 (diff)
downloadgentoo-3228548f74cc3faa12e0415733eadebace926fc2.tar.gz
gentoo-3228548f74cc3faa12e0415733eadebace926fc2.tar.bz2
gentoo-3228548f74cc3faa12e0415733eadebace926fc2.zip
x11-drivers/nvidia-drivers: extend postinst mismatch warning
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.182.03-r1.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-515.105.01-r1.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-525.116.04-r1.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-530.41.03-r1.ebuild7
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-535.43.02-r1.ebuild7
7 files changed, 42 insertions, 7 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild
index 1b767ce1a0dd..4395ca7609bb 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-390.157.ebuild
@@ -457,7 +457,12 @@ pkg_postinst() {
$(</proc/driver/nvidia/version) != *" ${PV} "* ]]; then
ewarn "Currently loaded NVIDIA modules do not match the newly installed"
ewarn "libraries and may prevent launching GPU-accelerated applications."
- use modules && ewarn "The easiest way to fix this is usually to reboot."
+ if use modules; then
+ ewarn "Easiest way to fix this is normally to reboot. If still run into issues"
+ ewarn "(e.g. API mismatch messages in the \`dmesg\` output), please verify"
+ ewarn "that the running kernel is ${KV_FULL} and that (if used) the"
+ ewarn "initramfs does not include NVIDIA modules (or at least, not old ones)."
+ fi
fi
ewarn
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.182.03-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.182.03-r1.ebuild
index d6dc7317d635..f92cf1cc0973 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.182.03-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.182.03-r1.ebuild
@@ -454,7 +454,12 @@ pkg_postinst() {
$(</proc/driver/nvidia/version) != *" ${PV} "* ]]; then
ewarn "Currently loaded NVIDIA modules do not match the newly installed"
ewarn "libraries and may prevent launching GPU-accelerated applications."
- use modules && ewarn "The easiest way to fix this is usually to reboot."
+ if use modules; then
+ ewarn "Easiest way to fix this is normally to reboot. If still run into issues"
+ ewarn "(e.g. API mismatch messages in the \`dmesg\` output), please verify"
+ ewarn "that the running kernel is ${KV_FULL} and that (if used) the"
+ ewarn "initramfs does not include NVIDIA modules (or at least, not old ones)."
+ fi
fi
if [[ $(</proc/cmdline) == *slub_debug=[!-]* ]]; then
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-515.105.01-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-515.105.01-r1.ebuild
index b8586f19f973..69acddc4ff35 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-515.105.01-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-515.105.01-r1.ebuild
@@ -508,7 +508,12 @@ pkg_postinst() {
$(</proc/driver/nvidia/version) != *" ${PV} "* ]]; then
ewarn "Currently loaded NVIDIA modules do not match the newly installed"
ewarn "libraries and may prevent launching GPU-accelerated applications."
- use modules && ewarn "The easiest way to fix this is usually to reboot."
+ if use modules; then
+ ewarn "Easiest way to fix this is normally to reboot. If still run into issues"
+ ewarn "(e.g. API mismatch messages in the \`dmesg\` output), please verify"
+ ewarn "that the running kernel is ${KV_FULL} and that (if used) the"
+ ewarn "initramfs does not include NVIDIA modules (or at least, not old ones)."
+ fi
fi
if [[ $(</proc/cmdline) == *slub_debug=[!-]* ]]; then
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.04-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.04-r1.ebuild
index 783ecf862bca..b821ca109c90 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.04-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.04-r1.ebuild
@@ -506,7 +506,12 @@ pkg_postinst() {
$(</proc/driver/nvidia/version) != *" ${PV} "* ]]; then
ewarn "Currently loaded NVIDIA modules do not match the newly installed"
ewarn "libraries and may prevent launching GPU-accelerated applications."
- use modules && ewarn "The easiest way to fix this is usually to reboot."
+ if use modules; then
+ ewarn "Easiest way to fix this is normally to reboot. If still run into issues"
+ ewarn "(e.g. API mismatch messages in the \`dmesg\` output), please verify"
+ ewarn "that the running kernel is ${KV_FULL} and that (if used) the"
+ ewarn "initramfs does not include NVIDIA modules (or at least, not old ones)."
+ fi
fi
if [[ $(</proc/cmdline) == *slub_debug=[!-]* ]]; then
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild
index 1035ce287cd4..43bc207ec36d 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26-r1.ebuild
@@ -507,7 +507,12 @@ pkg_postinst() {
$(</proc/driver/nvidia/version) != *" ${PV} "* ]]; then
ewarn "Currently loaded NVIDIA modules do not match the newly installed"
ewarn "libraries and may prevent launching GPU-accelerated applications."
- use modules && ewarn "The easiest way to fix this is usually to reboot."
+ if use modules; then
+ ewarn "Easiest way to fix this is normally to reboot. If still run into issues"
+ ewarn "(e.g. API mismatch messages in the \`dmesg\` output), please verify"
+ ewarn "that the running kernel is ${KV_FULL} and that (if used) the"
+ ewarn "initramfs does not include NVIDIA modules (or at least, not old ones)."
+ fi
fi
if [[ $(</proc/cmdline) == *slub_debug=[!-]* ]]; then
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-530.41.03-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-530.41.03-r1.ebuild
index b9a10a17cc75..377300e2f9df 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-530.41.03-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-530.41.03-r1.ebuild
@@ -506,7 +506,12 @@ pkg_postinst() {
$(</proc/driver/nvidia/version) != *" ${PV} "* ]]; then
ewarn "Currently loaded NVIDIA modules do not match the newly installed"
ewarn "libraries and may prevent launching GPU-accelerated applications."
- use modules && ewarn "The easiest way to fix this is usually to reboot."
+ if use modules; then
+ ewarn "Easiest way to fix this is normally to reboot. If still run into issues"
+ ewarn "(e.g. API mismatch messages in the \`dmesg\` output), please verify"
+ ewarn "that the running kernel is ${KV_FULL} and that (if used) the"
+ ewarn "initramfs does not include NVIDIA modules (or at least, not old ones)."
+ fi
fi
if [[ $(</proc/cmdline) == *slub_debug=[!-]* ]]; then
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-535.43.02-r1.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-535.43.02-r1.ebuild
index 1f3fc2044bc9..908c41c31895 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-535.43.02-r1.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-535.43.02-r1.ebuild
@@ -516,7 +516,12 @@ pkg_postinst() {
$(</proc/driver/nvidia/version) != *" ${PV} "* ]]; then
ewarn "Currently loaded NVIDIA modules do not match the newly installed"
ewarn "libraries and may prevent launching GPU-accelerated applications."
- use modules && ewarn "The easiest way to fix this is usually to reboot."
+ if use modules; then
+ ewarn "Easiest way to fix this is normally to reboot. If still run into issues"
+ ewarn "(e.g. API mismatch messages in the \`dmesg\` output), please verify"
+ ewarn "that the running kernel is ${KV_FULL} and that (if used) the"
+ ewarn "initramfs does not include NVIDIA modules (or at least, not old ones)."
+ fi
fi
if [[ $(</proc/cmdline) == *slub_debug=[!-]* ]]; then