summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2023-05-24 19:27:12 -0400
committerIonen Wolkens <ionen@gentoo.org>2023-05-24 19:34:44 -0400
commit47276c06c967efdddba8181ee1481a031653bd51 (patch)
treee522840eb43dda79180d5ed20f38f0d333550fc8 /x11-drivers
parentsci-mathematics/lean: bump to 3.51.1 (diff)
downloadgentoo-47276c06c967efdddba8181ee1481a031653bd51.tar.gz
gentoo-47276c06c967efdddba8181ee1481a031653bd51.tar.bz2
gentoo-47276c06c967efdddba8181ee1481a031653bd51.zip
x11-drivers/nvidia-drivers: soften IBT warning
The situation around this is still unclear, getting conflicting reports and (if actually fixed), it's still unclear which versions have received backports. Does not help that, at least initially, it was only fixed with USE=kernel-open because (unlike nvidia last I know of) we are using a newer gcc. And then changelog entries often have mixups (and wrt news outlets, afaik all they did is read these). If anyone reading this actually uses IBT, please send a report if the blob works as intended. Not changing 390's ebuild given that one is almost certainly broken. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-drivers')
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-470.182.03.ebuild5
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-515.105.01.ebuild5
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-525.116.03.ebuild5
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-525.116.04.ebuild5
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26.ebuild5
-rw-r--r--x11-drivers/nvidia-drivers/nvidia-drivers-530.41.03.ebuild5
6 files changed, 18 insertions, 12 deletions
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-470.182.03.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-470.182.03.ebuild
index 2abb35e6737e..0d0e1a3a178d 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-470.182.03.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-470.182.03.ebuild
@@ -100,8 +100,9 @@ pkg_setup() {
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, be warned the modules may not load.
- If run into problems, either unset or try to pass ibt=off to the kernel."
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, this should be fine and is supposed
+ to be fixed but, *if* modules fail to load, then try to either unset
+ or pass ibt=off to the kernel (ignore this message otherwise)"
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-515.105.01.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-515.105.01.ebuild
index 7fcb405e6acf..f7417cec22da 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-515.105.01.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-515.105.01.ebuild
@@ -105,8 +105,9 @@ pkg_setup() {
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, be warned the modules may not load.
- If run into problems, either unset or try to pass ibt=off to the kernel."
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, this should be fine and is supposed
+ to be fixed but, *if* modules fail to load, then try to either unset
+ or pass ibt=off to the kernel (ignore this message otherwise)"
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.03.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.03.ebuild
index 5b5b3da2dd33..6ae8b90eb1a9 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.03.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.03.ebuild
@@ -103,8 +103,9 @@ pkg_setup() {
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, be warned the modules may not load.
- If run into problems, either unset or try to pass ibt=off to the kernel."
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, this should be fine and is supposed
+ to be fixed but, *if* modules fail to load, then try to either unset
+ or pass ibt=off to the kernel (ignore this message otherwise)"
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.04.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.04.ebuild
index 5b5b3da2dd33..6ae8b90eb1a9 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.04.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-525.116.04.ebuild
@@ -103,8 +103,9 @@ pkg_setup() {
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, be warned the modules may not load.
- If run into problems, either unset or try to pass ibt=off to the kernel."
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, this should be fine and is supposed
+ to be fixed but, *if* modules fail to load, then try to either unset
+ or pass ibt=off to the kernel (ignore this message otherwise)"
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26.ebuild
index 5b421e2f5db7..e20c5bdc0474 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-525.47.26.ebuild
@@ -104,8 +104,9 @@ pkg_setup() {
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, be warned the modules may not load.
- If run into problems, either unset or try to pass ibt=off to the kernel."
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, this should be fine and is supposed
+ to be fixed but, *if* modules fail to load, then try to either unset
+ or pass ibt=off to the kernel (ignore this message otherwise)"
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764
diff --git a/x11-drivers/nvidia-drivers/nvidia-drivers-530.41.03.ebuild b/x11-drivers/nvidia-drivers/nvidia-drivers-530.41.03.ebuild
index 9d2c16995c01..c8d2595c17a3 100644
--- a/x11-drivers/nvidia-drivers/nvidia-drivers-530.41.03.ebuild
+++ b/x11-drivers/nvidia-drivers/nvidia-drivers-530.41.03.ebuild
@@ -103,8 +103,9 @@ pkg_setup() {
Cannot be directly selected in the kernel's menuconfig, and may need
selection of a DRM device even if unused, e.g. CONFIG_DRM_AMDGPU=m or
DRM_I915=y, DRM_NOUVEAU=m also acceptable if a module and not built-in."
- local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, be warned the modules may not load.
- If run into problems, either unset or try to pass ibt=off to the kernel."
+ local ERROR_X86_KERNEL_IBT="CONFIG_X86_KERNEL_IBT: is set, this should be fine and is supposed
+ to be fixed but, *if* modules fail to load, then try to either unset
+ or pass ibt=off to the kernel (ignore this message otherwise)"
use amd64 && kernel_is -ge 5 8 && CONFIG_CHECK+=" X86_PAT" #817764