summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-06-29 23:56:49 +0200
committerMichał Górny <mgorny@gentoo.org>2017-06-30 00:22:11 +0200
commit016a6451f48216cbcdc0e2d0fdb342b9fae6a4fa (patch)
treeb1d109302927ea5195d3fc4ff98bdaca1e758b40 /x11-libs/libtinynotify-systemwide
parentx11-libs/libtinynotify-systemwide: Moved back to GitHub (diff)
downloadgentoo-016a6451f48216cbcdc0e2d0fdb342b9fae6a4fa.tar.gz
gentoo-016a6451f48216cbcdc0e2d0fdb342b9fae6a4fa.tar.bz2
gentoo-016a6451f48216cbcdc0e2d0fdb342b9fae6a4fa.zip
x11-libs/libtinynotify-systemwide: Modernize to EAPI=6
Diffstat (limited to 'x11-libs/libtinynotify-systemwide')
-rw-r--r--x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild18
-rw-r--r--x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild35
2 files changed, 28 insertions, 25 deletions
diff --git a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
index 5120a429ccd2..4543af991c3e 100644
--- a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
+++ b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-0.1.ebuild
@@ -1,9 +1,7 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
-
-inherit autotools-utils
+EAPI=6
DESCRIPTION="A system-wide notifications module for libtinynotify"
HOMEPAGE="https://github.com/mgorny/libtinynotify-systemwide/"
@@ -14,16 +12,22 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE="doc static-libs"
-RDEPEND="sys-process/procps
- x11-libs/libtinynotify"
+RDEPEND="sys-process/procps:0=
+ x11-libs/libtinynotify:0="
DEPEND="${RDEPEND}
virtual/pkgconfig
doc? ( dev-util/gtk-doc )"
src_configure() {
- myeconfargs=(
+ local myconf=(
$(use_enable doc gtk-doc)
+ $(use_enable static-libs static)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
}
diff --git a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild
index 8823fe38587e..d4effe7755cf 100644
--- a/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild
+++ b/x11-libs/libtinynotify-systemwide/libtinynotify-systemwide-9999.ebuild
@@ -1,43 +1,42 @@
# Copyright 1999-2017 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-#if LIVE
-AUTOTOOLS_AUTORECONF=yes
EGIT_REPO_URI="https://github.com/mgorny/${PN}.git"
-
-inherit git-r3
-#endif
-
-inherit autotools-utils
+inherit autotools git-r3
DESCRIPTION="A system-wide notifications module for libtinynotify"
HOMEPAGE="https://github.com/mgorny/libtinynotify-systemwide/"
-SRC_URI="https://github.com/mgorny/libtinynotify-systemwide/releases/download/${P}/${P}.tar.bz2"
+SRC_URI=""
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~amd64 ~x86"
+KEYWORDS=""
IUSE="doc static-libs"
RDEPEND="sys-process/procps:0=
x11-libs/libtinynotify:0="
DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-1.18
virtual/pkgconfig
doc? ( dev-util/gtk-doc )"
-#if LIVE
-KEYWORDS=
-SRC_URI=
-DEPEND="${DEPEND}
- >=dev-util/gtk-doc-1.18"
-#endif
+src_prepare() {
+ default
+ eautoreconf
+}
src_configure() {
- myeconfargs=(
+ local myconf=(
$(use_enable doc gtk-doc)
+ $(use_enable static-libs static)
)
- autotools-utils_src_configure
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
}