summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2017-12-19 04:34:52 +0100
committerLars Wendler <polynomial-c@gentoo.org>2017-12-19 04:34:52 +0100
commit78accd40b217d6839d401135a6182f2dc7fff710 (patch)
tree76545a32167b2b53e10b932856f02b0dc9d86f9c /x11-libs/libxkbcommon/libxkbcommon-0.8.0.ebuild
parentmedia-video/simplescreenrecorder: Synced live ebuild. (diff)
downloadgentoo-78accd40b217d6839d401135a6182f2dc7fff710.tar.gz
gentoo-78accd40b217d6839d401135a6182f2dc7fff710.tar.bz2
gentoo-78accd40b217d6839d401135a6182f2dc7fff710.zip
x11-libs/libxkbcommon: Bump to version 0.8.0
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'x11-libs/libxkbcommon/libxkbcommon-0.8.0.ebuild')
-rw-r--r--x11-libs/libxkbcommon/libxkbcommon-0.8.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-libs/libxkbcommon/libxkbcommon-0.8.0.ebuild b/x11-libs/libxkbcommon/libxkbcommon-0.8.0.ebuild
new file mode 100644
index 000000000000..0a4987e6ce5a
--- /dev/null
+++ b/x11-libs/libxkbcommon/libxkbcommon-0.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+XORG_MULTILIB="yes"
+
+if [[ ${PV} = *9999* ]]; then
+ GIT_ECLASS="git-r3"
+ EXPERIMENTAL="true"
+ EGIT_REPO_URI="https://github.com/xkbcommon/${PN}"
+else
+ XORG_BASE_INDIVIDUAL_URI=""
+ SRC_URI="https://xkbcommon.org/download/${P}.tar.xz"
+fi
+
+inherit xorg-2 ${GIT_ECLASS}
+
+DESCRIPTION="X.Org xkbcommon library"
+HOMEPAGE="https://xkbcommon.org/"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="X doc test"
+
+DEPEND="sys-devel/bison
+ X? (
+ >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb]
+ >=x11-proto/xproto-7.0.24[${MULTILIB_USEDEP}]
+ >=x11-proto/kbproto-1.0.6-r1[${MULTILIB_USEDEP}]
+ )
+ doc? ( app-doc/doxygen )"
+RDEPEND="X? ( >=x11-libs/libxcb-1.10[${MULTILIB_USEDEP},xkb] )"
+
+pkg_setup() {
+ XORG_CONFIGURE_OPTIONS=(
+ --with-xkb-config-root="${EPREFIX}/usr/share/X11/xkb"
+ $(use X || use_enable X x11)
+ $(use_with doc doxygen)
+ )
+ xorg-2_pkg_setup
+}