summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/cairo-clock
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/cairo-clock')
-rw-r--r--x11-misc/cairo-clock/Manifest2
-rw-r--r--x11-misc/cairo-clock/cairo-clock-0.3.3.ebuild39
-rw-r--r--x11-misc/cairo-clock/cairo-clock-0.3.4.ebuild32
-rw-r--r--x11-misc/cairo-clock/files/cairo-clock-0.3.3-gcc46.patch12
-rw-r--r--x11-misc/cairo-clock/metadata.xml5
5 files changed, 90 insertions, 0 deletions
diff --git a/x11-misc/cairo-clock/Manifest b/x11-misc/cairo-clock/Manifest
new file mode 100644
index 000000000000..6990ff87cfac
--- /dev/null
+++ b/x11-misc/cairo-clock/Manifest
@@ -0,0 +1,2 @@
+DIST cairo-clock-0.3.4.tar.gz 832968 SHA256 f310de5bc03473a190d691679a831cd305351744ccf6eb7701f43dda6cd98a8d
+DIST cairo-clock_0.3.3-1.tar.gz 1248398 SHA256 812ca12792940138ce4d154d1d0d7d1e37295cf06ac7caf02935d5ebf845dc4c
diff --git a/x11-misc/cairo-clock/cairo-clock-0.3.3.ebuild b/x11-misc/cairo-clock/cairo-clock-0.3.3.ebuild
new file mode 100644
index 000000000000..c6f809451e99
--- /dev/null
+++ b/x11-misc/cairo-clock/cairo-clock-0.3.3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=2
+
+inherit autotools base
+
+DESCRIPTION="An analog clock displaying the system-time"
+HOMEPAGE="http://macslow.thepimp.net/?page_id=23"
+SRC_URI="http://macslow.thepimp.net/projects/${PN}/${PN}_${PV}-1.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~x86 ~x86-fbsd"
+IUSE=""
+PATCHES=( "${FILESDIR}/${P}-gcc46.patch" )
+
+RDEPEND="dev-libs/glib:2
+ gnome-base/libglade
+ gnome-base/librsvg
+ >=x11-libs/cairo-1.2
+ x11-libs/gtk+:2
+ >=x11-libs/pango-1.10"
+DEPEND="${DEPEND}
+ virtual/pkgconfig
+ dev-util/intltool
+ sys-devel/gettext"
+
+src_prepare() {
+ base_src_prepare
+ intltoolize --force --copy --automake || die "intltoolize failed"
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS BUGS ChangeLog NEWS README TODO
+}
diff --git a/x11-misc/cairo-clock/cairo-clock-0.3.4.ebuild b/x11-misc/cairo-clock/cairo-clock-0.3.4.ebuild
new file mode 100644
index 000000000000..025ee8c4ae95
--- /dev/null
+++ b/x11-misc/cairo-clock/cairo-clock-0.3.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+
+DESCRIPTION="An analog clock displaying the system-time"
+HOMEPAGE="http://macslow.net/?page_id=23"
+SRC_URI="http://macslow.thepimp.net/projects/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.8
+ >=gnome-base/libglade-2.6
+ >=gnome-base/librsvg-2.14
+ >=x11-libs/cairo-1.2
+ >=x11-libs/gtk+-2.10:2
+ >=x11-libs/pango-1.10"
+DEPEND="${DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ sys-devel/gettext"
+
+DOCS=( AUTHORS NEWS README TODO )
+
+src_prepare() {
+ # cc: error: unrecognized option '--export-dynamic'
+ sed -i -e '/cairo_clock_LDFLAGS/s:=.*:= -rdynamic:' src/Makefile.in || die
+}
diff --git a/x11-misc/cairo-clock/files/cairo-clock-0.3.3-gcc46.patch b/x11-misc/cairo-clock/files/cairo-clock-0.3.3-gcc46.patch
new file mode 100644
index 000000000000..76569cc84260
--- /dev/null
+++ b/x11-misc/cairo-clock/files/cairo-clock-0.3.3-gcc46.patch
@@ -0,0 +1,12 @@
+diff -uNr cairo-clock-0.3.3.ORIG/src/Makefile.am cairo-clock-0.3.3/src/Makefile.am
+--- cairo-clock-0.3.3.ORIG/src/Makefile.am 2011-09-24 12:42:48.862380207 +0100
++++ cairo-clock-0.3.3/src/Makefile.am 2011-09-24 12:43:29.135381441 +0100
+@@ -1,7 +1,7 @@
+ bin_PROGRAMS = cairo_clock
+ transform = s/_/-/g
+
+-cairo_clock_LDFLAGS = -Wl, --export-dynamic
++cairo_clock_LDFLAGS = -rdynamic
+
+ cairo_clock_LDADD = \
+ $(GLIB_LIBS) \
diff --git a/x11-misc/cairo-clock/metadata.xml b/x11-misc/cairo-clock/metadata.xml
new file mode 100644
index 000000000000..731225048652
--- /dev/null
+++ b/x11-misc/cairo-clock/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>desktop-misc</herd>
+</pkgmetadata>