summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Jordan <immoloism@gmail.com>2023-12-18 05:53:24 +0000
committerSam James <sam@gentoo.org>2023-12-21 11:49:47 +0000
commite8d58bbd4ebc4c4b2f0817224e3b0ef816a806cb (patch)
treeed68f1cbaffcea6b6382ed4e0f7efcb55c6f12a4 /x11-misc/mozo
parentapp-editors/pluma: add 1.27.0 (diff)
downloadgentoo-e8d58bbd4ebc4c4b2f0817224e3b0ef816a806cb.tar.gz
gentoo-e8d58bbd4ebc4c4b2f0817224e3b0ef816a806cb.tar.bz2
gentoo-e8d58bbd4ebc4c4b2f0817224e3b0ef816a806cb.zip
x11-misc/mozo: add 1.27.0
Signed-off-by: Ian Jordan <immoloism@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-misc/mozo')
-rw-r--r--x11-misc/mozo/Manifest1
-rw-r--r--x11-misc/mozo/mozo-1.27.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-misc/mozo/Manifest b/x11-misc/mozo/Manifest
index 2cabad745d42..6ed3bbe37250 100644
--- a/x11-misc/mozo/Manifest
+++ b/x11-misc/mozo/Manifest
@@ -1,2 +1,3 @@
DIST mozo-1.26.1.tar.xz 242836 BLAKE2B 59047b087e531792c0e831779d06a2dc7d9d2709bef7a7c8ba4a21d6f9fe1a79f917e2ba4e4912d655ad94391c0f7789e6ad6394be1a7bcb482881781f81c9ff SHA512 8570db4719d88bb34269a23acaa63638c5b7e50bf840bca73db718040c9d585670f1fd3be128c51ff22b4314f59dad6050907db8ce60bb506e4d46c3f807707e
DIST mozo-1.26.2.tar.xz 249672 BLAKE2B 95e9a04fc91424e8ce95e870253bf1d2eddfbbf1b78b632b15d057a3ffa86068bb2c89442cfc50c4f74a76e75b345c6b06cf47d5891eed3ffce460697fb0094b SHA512 c4ea00f97f4dd5c9b33b78e1b438ba80a5e23b69d05f6ea59c522a580c1b07c280cddc0591f266c16f39bbe5f3e07ca28cdbd33753162a02584b551a9857b904
+DIST mozo-1.27.0.tar.xz 249452 BLAKE2B d8fc5af3512ed1d8674dfecf0ff8639a3233559015d297d0891a4c36eabf4d9e7e315095395213a1b6a509f056071e83ba19253949f96c3ecff54517fec26156 SHA512 9ccc2d9d5420a4184599546639514379a4326017d90efe5849a72a4ab7e4e6fbd63d13e91db5867aa3fd620d2d8cd257d122bd977eede6f0852949c66c8f7981
diff --git a/x11-misc/mozo/mozo-1.27.0.ebuild b/x11-misc/mozo/mozo-1.27.0.ebuild
new file mode 100644
index 000000000000..50ba031278cf
--- /dev/null
+++ b/x11-misc/mozo/mozo-1.27.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="xml(+)"
+
+inherit mate python-r1
+
+DESCRIPTION="Mozo menu editor for MATE"
+LICENSE="GPL-2+ GPL-3+ LGPL-2+ LGPL-2.1+"
+
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~riscv ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+COMMON_DEPEND="${PYTHON_DEPS}
+ >=dev-python/pygobject-3:3[${PYTHON_USEDEP}]
+ >=mate-base/mate-menus-1.21.0[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ >=x11-libs/gtk+-3.12:3[introspection]
+"
+
+RDEPEND="${COMMON_DEPEND}
+ virtual/libintl
+"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ mate_src_prepare
+ python_copy_sources
+}
+
+src_configure() {
+ python_foreach_impl run_in_build_dir mate_src_configure \
+ --disable-icon-update
+}
+
+src_compile() {
+ python_foreach_impl run_in_build_dir default
+}
+
+src_test() {
+ python_foreach_impl run_in_build_dir emake check
+}
+
+src_install() {
+ installing() {
+ mate_src_install
+
+ # Massage shebang to make python_doscript happy
+ sed -e 's:#! '"${PYTHON}:#!/usr/bin/python:" \
+ -i mozo || die
+
+ python_doscript mozo
+ python_optimize
+ }
+
+ python_foreach_impl run_in_build_dir installing
+}