summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conrad@kostecki.com>2019-05-03 22:38:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2019-05-09 00:56:12 +0200
commitf5c489f0bc0c69fa0f9083538ae1b3c508dd43a6 (patch)
treed7ed8a094a8964a3d06f0c098b0881f16bac178f /x11-misc/xflux-gui
parentdev-python/pyTenable: bump to 0.3.19 (diff)
downloadgentoo-f5c489f0bc0c69fa0f9083538ae1b3c508dd43a6.tar.gz
gentoo-f5c489f0bc0c69fa0f9083538ae1b3c508dd43a6.tar.bz2
gentoo-f5c489f0bc0c69fa0f9083538ae1b3c508dd43a6.zip
x11-misc/xflux-gui: bump to version 1.2.0
Also bumped to EAPI=7 and migrated from gnome2-utils to xdg-utils. This version drops support for python2, but support for python3 was added. Package-Manager: Portage-2.3.65, Repoman-2.3.12 Signed-off-by: Conrad Kostecki <conrad@kostecki.com> Closes: https://github.com/gentoo/gentoo/pull/11793 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'x11-misc/xflux-gui')
-rw-r--r--x11-misc/xflux-gui/Manifest1
-rw-r--r--x11-misc/xflux-gui/xflux-gui-1.2.0.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/x11-misc/xflux-gui/Manifest b/x11-misc/xflux-gui/Manifest
index 2618b655026b..8642d080fb00 100644
--- a/x11-misc/xflux-gui/Manifest
+++ b/x11-misc/xflux-gui/Manifest
@@ -1,2 +1,3 @@
DIST fluxgui-a3b55da976053fc978b29d191db52dfb8da2f8ee.tar.gz 30667 BLAKE2B bb9b3d3fa2f40acf3248e5cdd91a82c3f736937c03451aba41280b25fc541a3db23c6a57f2ef97ac1ce415d289c0442a387462415827009c68f169f91da589e2 SHA512 d4571f3a64c1f532642f86d4de50d5807afb856179debab77e4495dc48060c68a635d38990d174fbb67169317d7107356344507285271b0bb058f056c1e39a37
DIST xflux-gui-1.1.10.tar.gz 18828 BLAKE2B a249533ace4ff6293ff9b99a455943c1f099628bec97c2730473f8a9550ba38e78e775a10a0f77c160180f5f5d354ac8c8ac924c1a2eb9f48861491583c93285 SHA512 5e8057e47fe2cc8a59758e9ab6b3adc6a8281b42f6b517e3e1327e5470c82a326c853d5d389fd62f6d6c439be4ab70a6c8771ece87e5b8c90a33775f8b7cd54d
+DIST xflux-gui-1.2.0.tar.gz 31831 BLAKE2B ad6b29f75cf5c287efdb4c1eaa12610a6fd2d4515e7f77cb991f0140d9de1128981ae274a1503f7c5bb83ff84f8dc124ba64e5abdd2e97c1d7157c84df51bead SHA512 244c11efbf58112d3d84209142faafbbe46b33df1edf13e122945ff767fc6a394c147979c0086bd88cb41ee7c80b5bd87016b3e158f3a959f3aca8bda47707d2
diff --git a/x11-misc/xflux-gui/xflux-gui-1.2.0.ebuild b/x11-misc/xflux-gui/xflux-gui-1.2.0.ebuild
new file mode 100644
index 000000000000..17a3f60962e4
--- /dev/null
+++ b/x11-misc/xflux-gui/xflux-gui-1.2.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="A GUI for f.lux"
+HOMEPAGE="https://justgetflux.com/"
+SRC_URI="https://github.com/${PN}/fluxgui/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+RDEPEND="
+ dev-libs/libappindicator:3
+ dev-python/pexpect[${PYTHON_USEDEP}]
+ dev-python/pygobject[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ x11-libs/libXxf86vm
+ x11-misc/xflux
+"
+
+S="${WORKDIR}/fluxgui-${PV}"
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+}