summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2023-10-15 21:23:18 -0400
committerMatt Turner <mattst88@gentoo.org>2023-10-15 22:11:47 -0400
commit1ebc21a701d01da56fb6575439968e50dd1ba744 (patch)
tree690fe1e31210feb6777293ea1504a6924bed58ca /x11-misc/xkeyboard-config
parentx11-misc/xkeyboard-config: Enable pytest test (diff)
downloadgentoo-1ebc21a701d01da56fb6575439968e50dd1ba744.tar.gz
gentoo-1ebc21a701d01da56fb6575439968e50dd1ba744.tar.bz2
gentoo-1ebc21a701d01da56fb6575439968e50dd1ba744.zip
x11-misc/xkeyboard-config: Version bump to 2.40
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-misc/xkeyboard-config')
-rw-r--r--x11-misc/xkeyboard-config/Manifest1
-rw-r--r--x11-misc/xkeyboard-config/xkeyboard-config-2.40.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/x11-misc/xkeyboard-config/Manifest b/x11-misc/xkeyboard-config/Manifest
index 5cc7fd109fdd..8a9f9ed1df67 100644
--- a/x11-misc/xkeyboard-config/Manifest
+++ b/x11-misc/xkeyboard-config/Manifest
@@ -1 +1,2 @@
DIST xkeyboard-config-2.39.tar.xz 896112 BLAKE2B d1ef598a0c1993518b01e73c319147ea1f3e55e1c8040762b9e95636c89d9b719322f3f2a1a87bffc545928b2912ead37f336182ba69d692893521322f170e21 SHA512 4690a0291c1f8c2c53b84984221a60a935c9b7cfc8ae20a8740403571f3704dedf06e5755b45775a15a5df21ebd2acac3ff785ff19f54d792ae359c4c6d60756
+DIST xkeyboard-config-2.40.tar.xz 893584 BLAKE2B 79dd20e588e72c9fe65ff0885889ae3e2ad0ffbb66b27cf90db36fecfd41f24667fcc0a0a7fc96f3bc5d01502532af3e6b560719413bc16529328dd02d353c92 SHA512 00c965e747169194d9a8d1ed0dfd544988c70df6a69888c50a06b4e266ce7047a8696ce408b9a7ba91e7e6b9679ab6e5f014308dbbf0a9c6be0e948d7646f878
diff --git a/x11-misc/xkeyboard-config/xkeyboard-config-2.40.ebuild b/x11-misc/xkeyboard-config/xkeyboard-config-2.40.ebuild
new file mode 100644
index 000000000000..4fcf0d647513
--- /dev/null
+++ b/x11-misc/xkeyboard-config/xkeyboard-config-2.40.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+inherit meson python-any-r1
+
+DESCRIPTION="X keyboard configuration database"
+HOMEPAGE="https://www.freedesktop.org/wiki/Software/XKeyboardConfig https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config"
+
+if [[ ${PV} == 9999 ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/xkeyboard-config/xkeyboard-config.git"
+ inherit git-r3
+else
+ SRC_URI="https://www.x.org/releases/individual/data/${PN}/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+ dev-lang/perl
+ dev-libs/libxslt
+ sys-devel/gettext
+ test? (
+ $(python_gen_any_dep '
+ dev-python/pytest[${PYTHON_USEDEP}]
+ ')
+ )
+"
+
+pkg_setup() {
+ python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local emesonargs=(
+ -Dxkb-base="${EPREFIX}/usr/share/X11/xkb"
+ -Dcompat-rules=true
+ )
+ meson_src_configure
+}