summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-misc/xsnap/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-misc/xsnap/files')
-rw-r--r--x11-misc/xsnap/files/xsnap-1.5.10-prefix.patch40
-rw-r--r--x11-misc/xsnap/files/xsnap-1.5.15-root_name.patch11
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-misc/xsnap/files/xsnap-1.5.10-prefix.patch b/x11-misc/xsnap/files/xsnap-1.5.10-prefix.patch
new file mode 100644
index 000000000000..ac4f96f3fd75
--- /dev/null
+++ b/x11-misc/xsnap/files/xsnap-1.5.10-prefix.patch
@@ -0,0 +1,40 @@
+From: Nathan Phillip Brink <binki@gentoo.org>
+Subject: Fix installation of xsnap on gentoo-prefix.
+
+--- a/po/Makefile
++++ b/po/Makefile
+@@ -19,7 +19,6 @@
+ # along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+ CATALOGS="fr"
+-LOCALEDIR=/usr/share/locale
+
+ all:
+ for cat in $(CATALOGS) ; do msgfmt -o $$cat.mo -v $$cat.po ; done
+
+--- a/Imakefile
++++ b/Imakefile
+@@ -37,9 +37,10 @@
+ /* This is the right link order [Steff] */
+ LOCAL_LIBRARIES = -lz $(XPMLIB) $(XFTLIB) $(PNGLIB) $(JPEGLIB) $(XLIB)
+
+- DEFINES = -DENABLE_NLS -DXPM -DPNG -DJPG -DPACKAGE=\"xsnap\" -DLOCALEDIR=\"/usr/share/locale\"
++LOCALEDIR = /usr/share/locale
++ DEFINES = -DENABLE_NLS -DXPM -DPNG -DJPG -DPACKAGE=\"xsnap\" -DLOCALEDIR=\"$(LOCALEDIR)\"
+
+-# DEFINES = -DXPM -DPNG -DJPG -DPACKAGE=\"xsnap\" -DLOCALEDIR=\"/usr/share/locale\"
++# DEFINES = -DXPM -DPNG -DJPG -DPACKAGE=\"xsnap\" -DLOCALEDIR=\"$(LOCALEDIR)\"
+
+ ComplexProgramTarget(xsnap)
+
+@@ -55,8 +56,8 @@
+ install::
+ cp -f xsnap-ocr $(DESTDIR)/$(BINDIR)
+ chmod a+rx $(DESTDIR)/$(BINDIR)/xsnap-ocr
+- cp -f xsnap.1.gz xsnap-ocr.1.gz $(DESTDIR)/usr/share/man/man1
+- cd po ; $(MAKE) install
++ cp -f xsnap.1.gz xsnap-ocr.1.gz $(DESTDIR)/$(MANDIR)
++ cd po ; $(MAKE) LOCALEDIR='$(LOCALEDIR)' install
+
+ clean::
+ cd po ; $(MAKE) clean
diff --git a/x11-misc/xsnap/files/xsnap-1.5.15-root_name.patch b/x11-misc/xsnap/files/xsnap-1.5.15-root_name.patch
new file mode 100644
index 000000000000..48076680f207
--- /dev/null
+++ b/x11-misc/xsnap/files/xsnap-1.5.15-root_name.patch
@@ -0,0 +1,11 @@
+--- a/xsnap.c
++++ b/xsnap.c
+@@ -2254,7 +2254,7 @@
+ if (op_mode == 0)
+ exitXsnap (NULL, NULL, snap_pixmap, copy_gc);
+
+- if (!root_name)
++ if (*root_name == '\0')
+ strcpy(output_name, "(stdout)");
+
+ if (op_mode == 2) {