summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-28 16:36:01 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-28 16:43:18 -0400
commit46a633809e757e7a2579c883468d242ed0af0890 (patch)
treefe4bd87420b9bdc26e38b9534e6afa4af3f3dd0a /x11-misc
parentx11-misc/obconf: EAPI7->8, tidy, use bit more pedantic deps (diff)
downloadgentoo-46a633809e757e7a2579c883468d242ed0af0890.tar.gz
gentoo-46a633809e757e7a2579c883468d242ed0af0890.tar.bz2
gentoo-46a633809e757e7a2579c883468d242ed0af0890.zip
x11-misc/obconf: fix build with clang16
Closes: https://bugs.gentoo.org/870538 Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/obconf/files/obconf-2.0.4_p20150213-clang16.patch19
-rw-r--r--x11-misc/obconf/obconf-2.0.4_p20150213-r1.ebuild4
2 files changed, 23 insertions, 0 deletions
diff --git a/x11-misc/obconf/files/obconf-2.0.4_p20150213-clang16.patch b/x11-misc/obconf/files/obconf-2.0.4_p20150213-clang16.patch
new file mode 100644
index 000000000000..4775005da274
--- /dev/null
+++ b/x11-misc/obconf/files/obconf-2.0.4_p20150213-clang16.patch
@@ -0,0 +1,19 @@
+https://bugs.gentoo.org/870538
+--- a/src/appearance.c
++++ b/src/appearance.c
+@@ -19,2 +19,3 @@
+
++#include <ctype.h>
+ #include "main.h"
+--- a/src/desktops.h
++++ b/src/desktops.h
+@@ -26,2 +26,3 @@
+ void desktops_setup_names(GtkWidget *w);
++void desktops_setup_tab(void);
+
+--- a/src/main.c
++++ b/src/main.c
+@@ -26,2 +26,3 @@
+ #include "mouse.h"
++#include "moveresize.h"
+ #include "desktops.h"
diff --git a/x11-misc/obconf/obconf-2.0.4_p20150213-r1.ebuild b/x11-misc/obconf/obconf-2.0.4_p20150213-r1.ebuild
index 3d916d661ce9..18c3479ac255 100644
--- a/x11-misc/obconf/obconf-2.0.4_p20150213-r1.ebuild
+++ b/x11-misc/obconf/obconf-2.0.4_p20150213-r1.ebuild
@@ -33,6 +33,10 @@ BDEPEND="
virtual/pkgconfig
nls? ( sys-devel/gettext )"
+PATCHES=(
+ "${FILESDIR}"/${P}-clang16.patch
+)
+
src_prepare() {
default