summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2021-01-18 12:16:19 +0000
committerMarek Szuba <marecki@gentoo.org>2021-01-18 12:27:47 +0000
commitadcb5f3db6bd34ba680427d0b921b0d9bb148dfe (patch)
treee894dde3ce3105b5a8a1e1c8529d9e8657d67450 /x11-plugins/vicious
parentx11-plugins/vicious: add current upstream GitHub remote to metadata (diff)
downloadgentoo-adcb5f3db6bd34ba680427d0b921b0d9bb148dfe.tar.gz
gentoo-adcb5f3db6bd34ba680427d0b921b0d9bb148dfe.tar.bz2
gentoo-adcb5f3db6bd34ba680427d0b921b0d9bb148dfe.zip
x11-plugins/vicious: bump to 2.5.0 and EAPI-7
Moreover, missing run-time dependencies of specific widgets are now communicated to the user using optfeature. Closes: https://bugs.gentoo.org/567766 Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'x11-plugins/vicious')
-rw-r--r--x11-plugins/vicious/Manifest1
-rw-r--r--x11-plugins/vicious/vicious-2.5.0.ebuild64
2 files changed, 65 insertions, 0 deletions
diff --git a/x11-plugins/vicious/Manifest b/x11-plugins/vicious/Manifest
index e6d51bb8110b..87c43cbe66b0 100644
--- a/x11-plugins/vicious/Manifest
+++ b/x11-plugins/vicious/Manifest
@@ -1,2 +1,3 @@
DIST vicious-2.3.1.tar.gz 47484 BLAKE2B 2ef6e51507faf7477800091c738e65184439caba9b79004b53f3a479f1370ca64046bc1664c6b746d8ab71370b36f29095406439e2a8fab7524e6bb190350fb7 SHA512 9e89d36d708a7ccdff206451dfb98db8455a16f9d2254167a446af91fadc2103a5274442f38ddf1eb919da23480b6790639cdbbde4a08bffc1cf9221622064c9
DIST vicious-2.3.3.tar.gz 50564 BLAKE2B f472b9e1514c9f731734e6512496da6ebb516a190225035811333ca7a275509828b8b4078d72856b5a488eeaee612e3070406138f1abd9de61aaa0f01ca370b9 SHA512 2549fa168a8c8cebcb9ecf1eafbc7658213b6a5487839e8acbc2aaed18f0d0b8081550ee7beb93770ae7e600158e12b99b9e1c29af8a8807bb200cc1cdf75807
+DIST vicious-2.5.0.tar.gz 67557 BLAKE2B ffbc1b3c0e32b554cc367a51e5e17130e1b9f7fed2e8505aaa1845719ecd6d465d43ba839ac3a9b73a87e43ff3144c2074f3750d5f67b516d033a74144e9e12f SHA512 deb21587d1d7f2e6e4dd77c74abbfa337acf6c99ef9bebc0e505f1508afc6e3b03f043a639f866fcda0191447c103d3fba51376682201482fb669a263321dee5
diff --git a/x11-plugins/vicious/vicious-2.5.0.ebuild b/x11-plugins/vicious/vicious-2.5.0.ebuild
new file mode 100644
index 000000000000..32f7e2f8ca29
--- /dev/null
+++ b/x11-plugins/vicious/vicious-2.5.0.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit optfeature
+
+DESCRIPTION="Modular widget library for x11-wm/awesome"
+HOMEPAGE="https://github.com/vicious-widgets/vicious"
+SRC_URI="https://github.com/${PN}-widgets/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="contrib"
+
+RDEPEND="x11-wm/awesome"
+
+src_install() {
+ insinto /usr/share/awesome/lib/vicious
+ doins -r widgets helpers.lua init.lua
+
+ if use contrib; then
+ insinto /usr/share/awesome/lib/vicious/contrib
+ doins contrib/*.lua
+ fi
+
+ einstalldocs
+}
+
+pkg_postinst() {
+ # Note that as of 2.5.0 this list may or may not be incomplete - it has been produced
+ # only by searching for occurrences of vicious.spawn (the recommended way of calling
+ # external helpers because it supports async) and popen (still used by many contrib widgets).
+ # Moreover, dependencies of all non-Linux widgets have been excluded on purpose.
+ elog "These widgets need some dependencies:"
+ optfeature "cmus" "media-sound/cmus"
+ optfeature "fs" "sys-apps/coreutils" # df
+ optfeature "gmail" "net-misc/curl"
+ optfeature "hddtemp" "net-misc/curl[telnet] app-admin/hddtemp"
+ optfeature "hwmontemp" "sys-apps/grep"
+ optfeature "mdir" "sys-apps/findutils"
+ optfeature "mpd" "net-misc/curl[telnet] media-sound/mpd"
+ optfeature "notmuch" "net-mail/notmuch"
+ optfeature "volume" "media-sound/alsa-utils" # amixer
+ optfeature "weather" "net-misc/curl"
+ optfeature "wifi" "net-wireless/wireless-tools"
+ optfeature "wifiiw" "net-wireless/iw"
+ if use contrib; then
+ optfeature "contrib/btc" "net-misc/curl"
+ optfeature "contrib/buildbot" "net-misc/curl"
+ optfeature "contrib/countfiles" "sys-apps/findutils"
+ optfeature "contrib/mpc" "media-sound/mpc"
+ optfeature "contrib/openweather" "net-misc/curl"
+ optfeature "contrib/netcfg" "sys-apps/coreutils" # ls
+ optfeature "contrib/nvinf" "x11-drivers/nvidia-drivers" # nvidia-settings
+ # ossvol needs 'ossmix' - not packaged?
+ optfeature "contrib/pulse" "media-sound/pulseaudio" # pacmd
+ optfeature "contrib/rss" "net-misc/curl"
+ optfeature "contrib/sensors" "sys-apps/lm-sensors"
+ optfeature "contrib/wpa" "net-wireless/wpa_supplicant" # wpa-cli
+ fi
+ elog
+}