summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-07-16 18:16:36 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-07-16 18:16:59 -0500
commit59635ed1891743343e8a1750f024a1ccc0153c23 (patch)
treee141e85d51fe5d8a9dbc44091e8c9722822f95f2 /x11-terms/kitty
parentsys-kernel/vanilla-sources: Version bump to 5.2.1 (diff)
downloadgentoo-59635ed1891743343e8a1750f024a1ccc0153c23.tar.gz
gentoo-59635ed1891743343e8a1750f024a1ccc0153c23.tar.bz2
gentoo-59635ed1891743343e8a1750f024a1ccc0153c23.zip
x11-terms/kitty: fix git master builds (patch fails)
Package-Manager: Portage-2.3.66, Repoman-2.3.16 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'x11-terms/kitty')
-rw-r--r--x11-terms/kitty/files/kitty-9999-flags.patch32
-rw-r--r--x11-terms/kitty/files/kitty-9999-svg-icon.patch14
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild2
3 files changed, 33 insertions, 15 deletions
diff --git a/x11-terms/kitty/files/kitty-9999-flags.patch b/x11-terms/kitty/files/kitty-9999-flags.patch
index fe54a959cb78..f7efa3b305b7 100644
--- a/x11-terms/kitty/files/kitty-9999-flags.patch
+++ b/x11-terms/kitty/files/kitty-9999-flags.patch
@@ -1,6 +1,6 @@
---- kitty-0.13.2/setup.py
-+++ kitty-0.13.2/setup.py
-@@ -178,7 +178,7 @@
+--- setup.py.orig 2019-07-16 18:04:24.052780940 -0500
++++ setup.py 2019-07-16 18:05:54.564383192 -0500
+@@ -202,7 +202,7 @@
df = '-g3'
if ccver >= (5, 0):
df += ' -Og'
@@ -8,8 +8,8 @@
+ optimize = ''
sanitize_args = get_sanitize_args(cc, ccver) if sanitize else set()
cppflags = os.environ.get(
- 'OVERRIDE_CPPFLAGS', (
-@@ -191,7 +191,7 @@
+ 'OVERRIDE_CPPFLAGS', '-D{}DEBUG'.format('' if debug else 'N'),
+@@ -213,7 +213,7 @@
cflags = os.environ.get(
'OVERRIDE_CFLAGS', (
'-Wextra -Wno-missing-field-initializers -Wall -Wstrict-prototypes -std=c11'
@@ -18,7 +18,7 @@
).format(
optimize,
' '.join(sanitize_args),
-@@ -205,7 +205,7 @@
+@@ -227,7 +227,7 @@
)
ldflags = os.environ.get(
'OVERRIDE_LDFLAGS',
@@ -27,21 +27,25 @@
)
ldflags = shlex.split(ldflags)
ldflags.append('-shared')
-@@ -517,14 +517,14 @@
+@@ -606,20 +606,17 @@
- def build_launcher(args, launcher_dir='.', for_bundle=False, sh_launcher=False, for_freeze=False):
+ def build_launcher(args, launcher_dir='.', bundle_type='source'):
- cflags = '-Wall -Werror -fpie'.split()
+ cflags = '-Wall -fpie'.split()
cppflags = []
libs = []
- if args.profile:
- cppflags.append('-DWITH_PROFILER'), cflags.append('-g')
- libs.append('-lprofiler')
+ if args.profile or args.sanitize:
+ if args.sanitize:
+- cflags.append('-g3')
+ cflags.extend(get_sanitize_args(env.cc, env.ccver))
+ libs += ['-lasan'] if env.cc == 'gcc' and not is_macos else []
+ else:
+ cflags.append('-g')
+ if args.profile:
+ libs.append('-lprofiler')
- else:
- cflags.append('-O3')
-+ #else:
-+ # cflags.append('-O3')
- if for_bundle or for_freeze:
+ if bundle_type.endswith('-freeze'):
cppflags.append('-DFOR_BUNDLE')
cppflags.append('-DPYVER="{}"'.format(sysconfig.get_python_version()))
diff --git a/x11-terms/kitty/files/kitty-9999-svg-icon.patch b/x11-terms/kitty/files/kitty-9999-svg-icon.patch
new file mode 100644
index 000000000000..ff9e00eb67c9
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-9999-svg-icon.patch
@@ -0,0 +1,14 @@
+--- kitty-9999/setup.py.orig 2019-07-16 18:13:07.072868752 -0500
++++ kitty-9999/setup.py 2019-07-16 18:13:40.082039929 -0500
+@@ -705,9 +705,9 @@
+ run_tool(['make', 'docs'])
+ copy_man_pages(ddir)
+ copy_html_docs(ddir)
+- icdir = os.path.join(ddir, 'share', 'icons', 'hicolor', '256x256', 'apps')
++ icdir = os.path.join(ddir, 'share', 'icons', 'hicolor', 'scalable', 'apps')
+ safe_makedirs(icdir)
+- shutil.copy2('logo/kitty.png', icdir)
++ shutil.copy2('logo/kitty.svg', icdir)
+ deskdir = os.path.join(ddir, 'share', 'applications')
+ safe_makedirs(deskdir)
+ with open(os.path.join(deskdir, 'kitty.desktop'), 'w') as f:
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index b56c1d4487fe..f9a458abd9ac 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -54,7 +54,7 @@ DEPEND="${RDEPEND}
PATCHES=(
"${FILESDIR}"/${P}-flags.patch
- "${FILESDIR}"/${PN}-0.11.0-svg-icon.patch
+ "${FILESDIR}"/${P}-svg-icon.patch
)
src_prepare() {