summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matthew@gentoo.org>2024-01-23 17:05:45 +0000
committerMatthew Smith <matthew@gentoo.org>2024-01-23 17:06:40 +0000
commit4dd4867e442c466c80148103ba8391a36512e159 (patch)
tree061d60a2df5a8e09672bcfa8bd4ec7929f4f8bf8 /x11-terms/zutty
parentx11-terms/zutty: remove github upstream metadata (diff)
downloadgentoo-4dd4867e442c466c80148103ba8391a36512e159.tar.gz
gentoo-4dd4867e442c466c80148103ba8391a36512e159.tar.bz2
gentoo-4dd4867e442c466c80148103ba8391a36512e159.zip
x11-terms/zutty: add 0.15
Signed-off-by: Matthew Smith <matthew@gentoo.org>
Diffstat (limited to 'x11-terms/zutty')
-rw-r--r--x11-terms/zutty/Manifest1
-rw-r--r--x11-terms/zutty/zutty-0.15.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-terms/zutty/Manifest b/x11-terms/zutty/Manifest
index 7bc3b54fefbe..34418f4e7b51 100644
--- a/x11-terms/zutty/Manifest
+++ b/x11-terms/zutty/Manifest
@@ -1,3 +1,4 @@
DIST zutty-0.13-waf 105632 BLAKE2B 9edbaab125e398d3e0794f0ea0650cda833514f7e571ce5549d74c563c6adfd4483af34be4845d67993fe14bcacee89c02a8ca221673c472f6b16c6e27c0ad4d SHA512 ab756b7e3248bd6b87a58fd94d8d786c058889fa5015a2ed2eb2a05869af898324297a903810e43899de8eb226dc30a0a9605d7fdf6bec3bc05c68b74907e79f
DIST zutty-0.13.tar.gz 348348 BLAKE2B 35887597798ecee4912a76d74e943ab93682ee637eed0966d70e198d64c9960060eeb1a0b93a76596dd77aeea99b897bd2d54900f10a41a6a786776a5f202997 SHA512 b6514299520562f3ca9f29c80d252a571c0347603c918d15dde095b92be8e96e23a249b23d1d0efc0d7aca03138c07913d7f3dc0f3e91c8bf04e78a3444ac43e
DIST zutty-0.14.tar.gz 351015 BLAKE2B 36dc0f285b48261e01b199bd047634f6893b9969766867a163a2e87d3169e5eb2ee6760dca7976bb93bbcbba2fed4e9d79230135605a8bd905e067686a3717e5 SHA512 d73894feefa1fb58c76aa5f9d68a47b9871ab8d02eb5dd2575769c4f082a65cb9df2bdb2478e5aa54d121eb19a16269f169e79d72f0df779760520f2d501c086
+DIST zutty-0.15.tar.gz 351752 BLAKE2B d7de40d490fb2674f939a20fde5f28d4438153a0a5397e801cbe255f3394f7d776107106882dab75fff51fa7d7de73e902679d9d0b4668f54e0417ae4cd95f9f SHA512 a0d482cc60ff3059c14f65fe0892ab81f793e1b98bb892136a7027399dac84360726187c9f47bdb40fcae0b9b361a929aba783c61fca7a57f844787c483c0884
diff --git a/x11-terms/zutty/zutty-0.15.ebuild b/x11-terms/zutty/zutty-0.15.ebuild
new file mode 100644
index 000000000000..b1b12b303269
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.15.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MY_COMMIT=3fb1516
+PYTHON_COMPAT=( python3_{9..12} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://git.hq.sig7.se/zutty.git"
+SRC_URI="https://git.hq.sig7.se/zutty.git/snapshot/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${P}-${MY_COMMIT}
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# It is possible to run the tests using virtualx, but it seems to take
+# screenshots of the terminal window, and compares checksums that never
+# seem to match.
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/freetype:2
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Remove default CXX/LDFLAGS, bug #830405.
+ "${FILESDIR}"/${PN}-0.12-cxxflags.patch
+)
+
+DOCS=( doc/KEYS.org doc/USAGE.org )