summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-08-17 07:15:13 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-08-17 07:24:39 -0400
commit31471eccad5c3c1e9498d04d8824fec8485bb38f (patch)
tree4f54c89bfa1c74daff1ff4a3c5c7dd499a097c56 /x11-terms
parentx11-terms/kitty-shell-integration: add 0.36.0 (diff)
downloadgentoo-31471eccad5c3c1e9498d04d8824fec8485bb38f.tar.gz
gentoo-31471eccad5c3c1e9498d04d8824fec8485bb38f.tar.bz2
gentoo-31471eccad5c3c1e9498d04d8824fec8485bb38f.zip
x11-terms/kitty-terminfo: add 0.36.0
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.36.0.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index c0812f585c8d..78b8cad50f6e 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.34.1.tar.xz 8176176 BLAKE2B c39709a065a04b04bf15e6decb9a96c1699c1082de44690c36e4e05a288f6835fa3c5dd059c363a272c98934b5c66cf5d79078b6403c7f15a9e94f3f72aa680c SHA512 1b361823741c8c2a6ce3c5d56d0cbbd51bd0a0d2574312ef5c05f359c70862e0889a9636e4b95865750cbd239b517763315ed0cf4ec46e1feaffc27cf20e0e66
DIST kitty-0.35.2.tar.xz 8220608 BLAKE2B 277803c7036890af34f2e0497ab1d33cb578cba4bfba425d6699e02e2106cde4e10f7dcc6859ce7eea1b4f34795a2f5180328665450ccb49d8a6da4183fa4f50 SHA512 edc78046f942965c823a1202a6d7c85cc2d2acb376824a0f5224d4ba6f48ed0978a00eb7a3e1e6053622a7d5fdcf80009ecfb61a63272cf407dd30f828f47b56
+DIST kitty-0.36.0.tar.xz 8850304 BLAKE2B 7070f1cd1f0dbdd11a91771c124d7278a4918f320b3f2bbc299cd1d5cab05e617761d97f2531736757788b130453de73951ee75a4d604ee99b8ef819080e58ac SHA512 910864d9f7d1015f42a641200a3bd3f8b682c108c6732a189098072e83bc263d53589e2dfb6e3383abc635f19d4476f3ab22bd24914c316416a8c9fd89d48b2f
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.36.0.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.36.0.ebuild
new file mode 100644
index 000000000000..b5c7cbc40759
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.36.0.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}