summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2023-02-19 23:03:36 +0100
committerDavid Seifert <soap@gentoo.org>2023-02-19 23:03:36 +0100
commitd16a7816ce9d9bd9a79423349cba7b3826017fdb (patch)
tree264e4ae198b212e3c8f882cd0939d01adfcc4340 /x11-themes/gtk-chtheme
parentx11-themes/goddard-backgrounds: update EAPI 6 -> 8 (diff)
downloadgentoo-d16a7816ce9d9bd9a79423349cba7b3826017fdb.tar.gz
gentoo-d16a7816ce9d9bd9a79423349cba7b3826017fdb.tar.bz2
gentoo-d16a7816ce9d9bd9a79423349cba7b3826017fdb.zip
x11-themes/gtk-chtheme: update EAPI 6 -> 8
Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-themes/gtk-chtheme')
-rw-r--r--x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r4.ebuild (renamed from x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r3.ebuild)23
1 files changed, 12 insertions, 11 deletions
diff --git a/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r3.ebuild b/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r4.ebuild
index bd7dd770de66..40828f11d52f 100644
--- a/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r3.ebuild
+++ b/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r4.ebuild
@@ -1,33 +1,33 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=8
+
inherit toolchain-funcs
DESCRIPTION="GTK-2.0 Theme Switcher"
HOMEPAGE="http://plasmasturm.org/programs/gtk-chtheme/"
SRC_URI="http://plasmasturm.org/programs/gtk-chtheme/${P}.tar.bz2"
-IUSE=""
+LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~arm ~arm64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-LICENSE="GPL-2"
RDEPEND="x11-libs/gtk+:2"
-DEPEND="${RDEPEND}
- virtual/pkgconfig"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/${P}-implicit.patch
- "${FILESDIR}/${P}-asneeded.patch" # Fix forced as-needed, bug #248655
- "${FILESDIR}/${P}-qgtkstyle.patch" # Make it work with qgtkstyle, bug #250504
+ "${FILESDIR}"/${P}-asneeded.patch # Fix forced as-needed, bug #248655
+ "${FILESDIR}"/${P}-qgtkstyle.patch # Make it work with qgtkstyle, bug #250504
)
src_prepare() {
- # QA: stop Makefile from stripping the binaries
- sed -i -e "s:strip:true:" "${S}"/Makefile || die "sed failed"
-
default
+
+ # QA: stop Makefile from stripping the binaries
+ sed -i -e "s:strip:true:" Makefile || die
}
src_compile() {
@@ -36,4 +36,5 @@ src_compile() {
src_install() {
emake DESTDIR="${ED}" install
+ einstalldocs
}