summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-11-02 08:00:15 +0100
committerMichał Górny <mgorny@gentoo.org>2024-11-02 08:09:27 +0100
commit14068ba439382356eb4caf083a4faa314afae6ba (patch)
tree2b28f8cfadc0fca45bb4f70fd555fafb97f522ef /xfce-base/libxfce4util
parentdev-build/xfce4-dev-tools: Bump to 4.19.4 (diff)
downloadgentoo-14068ba439382356eb4caf083a4faa314afae6ba.tar.gz
gentoo-14068ba439382356eb4caf083a4faa314afae6ba.tar.bz2
gentoo-14068ba439382356eb4caf083a4faa314afae6ba.zip
xfce-base/libxfce4util: Bump to 4.19.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/libxfce4util')
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.19.4.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index eadf0823f3d5..e4aba468a778 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4util-4.18.2.tar.bz2 514157 BLAKE2B 4c0479d3df308956cecb321783823c3d1f07622260a19b2e7c633a5de6d87a779f1196c10cc5078b01bfabc7ca0cac9a819084414f2dcfbaef3d6d9a69ef3df8 SHA512 94c7371bcfd4ea8dca68a2dc2fe029ce8b232b2b906247bb45a830f13a27833e80831bb6df029d634e6cd8496d4cdcbb9691b6c4344aa51292477f2ebf56bac0
DIST libxfce4util-4.19.3.tar.bz2 622911 BLAKE2B 0bbe4b6085762d7ab53cb54228cf153e96d6d7c1987bd14fd0f5b0697a0bbf06aa4e969760104b650cc27bfd5a502750e5d1a5b2af7813746bb76528a1c6693d SHA512 0e869f0b850d6454c52a5e43b42ef5f56432ed69774bbf5ba8883d6d2fd8c2e9fccf471c684eb7577617f6286696dfd60ae4f5803c8d45002236289a5d4e5bff
+DIST libxfce4util-4.19.4.tar.bz2 614009 BLAKE2B 5f836fac969df8ec6f711230861624cd62c16c130c94c9908ccc922d57b0762a5ee3d6e70341c96646e89af4d6bc8bc18416f0f95cc59156f2c64aac0b991295 SHA512 742da219a4e0813ff3211ce4ad2f1e4484cc53ee7451bcad8ce18cb958b19fb0612015d673d45cf75466f204e9c47c2f6caa8ca6148999840e127cc268f61d91
diff --git a/xfce-base/libxfce4util/libxfce4util-4.19.4.ebuild b/xfce-base/libxfce4util/libxfce4util-4.19.4.ebuild
new file mode 100644
index 000000000000..dd1032f6c7d4
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.19.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/libxfce4util/start
+ https://gitlab.xfce.org/xfce/libxfce4util/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.72.0
+ introspection? ( >=dev-libs/gobject-introspection-1.72.0:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}