summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-03-28 19:52:21 +0200
committerMichał Górny <mgorny@gentoo.org>2023-03-28 20:13:37 +0200
commit0841049a17592bd54de8a7de237aba827d7cbb17 (patch)
treed29d87eff5addfd38a4518883ebd9a42ed63a096 /xfce-base
parentxfce-base/libxfce4ui: Bump to 4.18.3 (diff)
downloadgentoo-0841049a17592bd54de8a7de237aba827d7cbb17.tar.gz
gentoo-0841049a17592bd54de8a7de237aba827d7cbb17.tar.bz2
gentoo-0841049a17592bd54de8a7de237aba827d7cbb17.zip
xfce-base/garcon: Bump to 4.18.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/garcon/Manifest1
-rw-r--r--xfce-base/garcon/garcon-4.18.1.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/xfce-base/garcon/Manifest b/xfce-base/garcon/Manifest
index 39c2a59a46bf..9a3e557a3838 100644
--- a/xfce-base/garcon/Manifest
+++ b/xfce-base/garcon/Manifest
@@ -1 +1,2 @@
DIST garcon-4.18.0.tar.bz2 550674 BLAKE2B 93bc218c4455c61109ee7086a8cb822aaa154aaebd082c10ae9fd551019bce0fe68a117552c05fbe3a97c671036b5306703ba3c320d9b886715a83fb038c95b0 SHA512 c4b49ba47ac33823199a68ef9bdcba3acfcedde62a96a8a8b3af2bb1f28b3a5fe3e960ee93bdb964fbc01b039047d77f58fbe5b1f9fbd2ccd3d3f968e416a55c
+DIST garcon-4.18.1.tar.bz2 554562 BLAKE2B 395cc8f7c7029196f25ecb52d393989ab0df0d9ddd34ec1fc4b0a2ee46b1a059a87c75797adb84d7557523e8e0c464278344fe3d793f05941a90874bdc8e036d SHA512 8e6d091beaf1aaa85cc16cd5e562191e0e6858a47444a23d95066f9afa3f8a70f7a61bc9fec33fe401945637e810441cbd6f961f41b40e2d2ce7a1ce4fce78a0
diff --git a/xfce-base/garcon/garcon-4.18.1.ebuild b/xfce-base/garcon/garcon-4.18.1.ebuild
new file mode 100644
index 000000000000..1ab860690142
--- /dev/null
+++ b/xfce-base/garcon/garcon-4.18.1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce's freedesktop.org specification compatible menu implementation library"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/garcon/start
+ https://gitlab.xfce.org/xfce/garcon/
+"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ FDL-1.1+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="introspection"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ >=x11-libs/gtk+-3.24.0:3
+ >=xfce-base/libxfce4util-4.15.6:=[introspection?]
+ >=xfce-base/libxfce4ui-4.15.7:=[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/glib-utils
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig
+ introspection? ( >=dev-libs/gobject-introspection-1.66 )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ )
+
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}