summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-29 15:43:24 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-29 15:43:24 +0100
commit482dbb9b224f2c2686ad7016ece89fd1a1832ef1 (patch)
tree8613badf84b14c9b77d53c3b6303a3e2bfb502d8 /xfce-base
parentx11-terms/xfce4-terminal: Bump to 1.1.3 (diff)
downloadgentoo-482dbb9b224f2c2686ad7016ece89fd1a1832ef1.tar.gz
gentoo-482dbb9b224f2c2686ad7016ece89fd1a1832ef1.tar.bz2
gentoo-482dbb9b224f2c2686ad7016ece89fd1a1832ef1.zip
xfce-base/xfconf: Bump to 4.19.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/xfconf/Manifest1
-rw-r--r--xfce-base/xfconf/xfconf-4.19.2.ebuild77
2 files changed, 78 insertions, 0 deletions
diff --git a/xfce-base/xfconf/Manifest b/xfce-base/xfconf/Manifest
index c0d2ac8297fa..f0bf705eb613 100644
--- a/xfce-base/xfconf/Manifest
+++ b/xfce-base/xfconf/Manifest
@@ -1,2 +1,3 @@
DIST xfconf-4.18.3.tar.bz2 648479 BLAKE2B 021198bba84c651f05cf47a1034617e088dcce6502eac6f0f160f8000e2309bac5f44b57cc0a4156f907a25002cc3c539ab0c16fc5b3018bbc8ae9a58b212133 SHA512 e1aa133f79ea584af067369f6fd059cd444c4743270ed90a8b0dfe158f7ae6fbc78af62fab67c64674060c2fd1404f06602ac8c019b0db8b70779a17fde4a327
DIST xfconf-4.19.1.tar.bz2 762466 BLAKE2B dd0ae72fc5ccb1146d69e1e0a9b67e89205ea460f75fcc4ccee1cb36b600f5b145f75d9f10f576bc3040bd065aa8d855788e79fde78541c9853f3cf04f0b5bb3 SHA512 4adb08005caf8373da82ef8db1bfde1f91d723c73b8c836516611d52ccbed86eea6a8dbef8e2a17b9eb4d5199c54bfbfdec970836bb35eb1a951584d75c8faa3
+DIST xfconf-4.19.2.tar.bz2 764445 BLAKE2B d8deed120a8f6b901c544edff48f5748d5d0959cba886a817dc61cefca3cf169d7d557f2ac23c7167f0d294d8cee649d391041250a5475315f9b81e55be5de4c SHA512 fc72592013c2d9375ca66b917585506083e05d60325ced3b2c00877404b4c188ca028c7a213f50a2bf88ec8590864200f32c7fb56df2993baa233abbc1871673
diff --git a/xfce-base/xfconf/xfconf-4.19.2.ebuild b/xfce-base/xfconf/xfconf-4.19.2.ebuild
new file mode 100644
index 000000000000..e4afc552334d
--- /dev/null
+++ b/xfce-base/xfconf/xfconf-4.19.2.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit bash-completion-r1 vala
+
+DESCRIPTION="A configuration management system for Xfce"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+HOMEPAGE="
+ https://docs.xfce.org/xfce/xfconf/start
+ https://gitlab.xfce.org/xfce/xfconf/
+"
+
+LICENSE="GPL-2+"
+SLOT="0/3"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris"
+IUSE="debug +introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+DEPEND="
+ >=dev-libs/glib-2.66.0
+ sys-apps/dbus
+ >=xfce-base/libxfce4util-4.17.3:=
+ introspection? ( >=dev-libs/gobject-introspection-1.66:= )
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )
+"
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ $(use_enable debug checks)
+ --with-bash-completion-dir="$(get_bashcompdir)"
+ )
+
+ use vala && vala_setup
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ local service_dir=${HOME}/.local/share/dbus-1/services
+ mkdir -p "${service_dir}" || die
+ cat > "${service_dir}/org.xfce.Xfconf.service" <<-EOF || die
+ [D-BUS Service]
+ Name=org.xfce.Xfconf
+ Exec=${S}/xfconfd/xfconfd
+ EOF
+
+ (
+ # start isolated dbus session bus
+ dbus_data=$(dbus-launch --sh-syntax) || exit
+ eval "${dbus_data}"
+
+ # -j>1 often hangs
+ # https://gitlab.xfce.org/xfce/xfconf/-/issues/13
+ nonfatal emake -j1 check
+ ret=${?}
+
+ kill "${DBUS_SESSION_BUS_PID}"
+ exit "${ret}"
+ ) || die
+}
+
+src_install() {
+ default
+ find "${D}" -type f -name '*.la' -delete || die
+}