summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-25 18:01:33 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-25 18:01:33 +0100
commit66c21dbdac92e296c268bb2ec4c54c5a44b10f51 (patch)
tree4f9c062f11649bfd8d26c3c69f3159045229fb57 /xfce-extra
parentmedia-gfx/ristretto: Bump to 0.13.3 (diff)
downloadgentoo-66c21dbdac92e296c268bb2ec4c54c5a44b10f51.tar.gz
gentoo-66c21dbdac92e296c268bb2ec4c54c5a44b10f51.tar.bz2
gentoo-66c21dbdac92e296c268bb2ec4c54c5a44b10f51.zip
xfce-extra/xfce4-panel-profiles: Bump to 1.0.15
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-panel-profiles/Manifest1
-rw-r--r--xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.15.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-panel-profiles/Manifest b/xfce-extra/xfce4-panel-profiles/Manifest
index f35e422c03aa..9170213f479d 100644
--- a/xfce-extra/xfce4-panel-profiles/Manifest
+++ b/xfce-extra/xfce4-panel-profiles/Manifest
@@ -1 +1,2 @@
DIST xfce4-panel-profiles-1.0.14.tar.bz2 101521 BLAKE2B 197ebba356e8d7661779531147b08454762a9b61beebd2323bc9e88b26381952c2caa58c6fb110680a5038fc19422852722d72dfde09addb68ec9424ecf16a23 SHA512 e316e9d4f0d27b16ce83a50adfe1a3fe2102b7f5c3ed9e9ceebf5968e265064b4d4ade1e0dbd84180758a9c1fa72d8df1fb4d06a631d07956ea8add0f66da984
+DIST xfce4-panel-profiles-1.0.15.tar.bz2 121102 BLAKE2B 7a5a1ba1e3ca565110f3fd962330f176d0e914f3b9154bf95bdbdb3d8b650bbe764751d1d745b601005ae1a52f85bae8f7db8467ff7ae93beb5d012296d860fe SHA512 cf836c318985619f4b74eca3cd54a91c8b6df5758395ae043272eb6056e551e7ecaefb57fc32b7c46d0082336cd44bae5aae95177440210cc6e446835b70b3f1
diff --git a/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.15.ebuild b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.15.ebuild
new file mode 100644
index 000000000000..275e605f5c73
--- /dev/null
+++ b/xfce-extra/xfce4-panel-profiles/xfce4-panel-profiles-1.0.15.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit python-single-r1 xdg-utils
+
+DESCRIPTION="Simple application to manage Xfce panel layouts"
+HOMEPAGE="
+ https://docs.xfce.org/apps/xfce4-panel-profiles/start
+ https://gitlab.xfce.org/apps/xfce4-panel-profiles/
+"
+SRC_URI="
+ https://archive.xfce.org/src/apps/xfce4-panel-profiles/$(ver_cut 1-2)/${P}.tar.bz2
+"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="
+ ${PYTHON_DEPS}
+"
+RDEPEND="
+ ${BDEPEND}
+ dev-libs/gobject-introspection
+ $(python_gen_cond_dep '
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ ')
+ x11-libs/gtk+:3[introspection]
+ xfce-base/libxfce4ui[introspection]
+ xfce-base/xfce4-panel
+"
+
+src_configure() {
+ # home-made configure script, yay!
+ ./configure \
+ --prefix="${EPREFIX}/usr" \
+ --python="${EPYTHON}" \
+ --docdir="${EPREFIX}/usr/share/doc/${PF}" || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}