summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-24 12:13:48 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-24 12:17:22 +0100
commit805420c81fa9592ff3185d4066d164c512d6f55b (patch)
treec67cb11cd068e13e194c058cfbd55744379e1818 /xfce-extra
parentxfce-extra/xfce4-clipman-plugin: Bump to 1.6.7 (diff)
downloadgentoo-805420c81fa9592ff3185d4066d164c512d6f55b.tar.gz
gentoo-805420c81fa9592ff3185d4066d164c512d6f55b.tar.bz2
gentoo-805420c81fa9592ff3185d4066d164c512d6f55b.zip
xfce-extra/xfce4-battery-plugin: Bump to 1.1.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-battery-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.6.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-battery-plugin/Manifest b/xfce-extra/xfce4-battery-plugin/Manifest
index e9925d753027..454ed13ffb22 100644
--- a/xfce-extra/xfce4-battery-plugin/Manifest
+++ b/xfce-extra/xfce4-battery-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-battery-plugin-1.1.5.tar.bz2 465191 BLAKE2B 6aa8f1d3cd3dbf3fe29fede154ad51c7cf521c04191699582678e930c2ff0a20c2f50bda22d9576b1f29b595767c5ee1ce4a7ef60cdf3fd69271796d2af8ae2e SHA512 e6e09a4839911dda50fe1fed100d5fd46f6da47e5042529c2cbffa5498babc838bed56178baa23d2162b70cd6e5f005276d4b9f1fc44a1891737c94c2bf525d0
+DIST xfce4-battery-plugin-1.1.6.tar.bz2 569701 BLAKE2B 5f401ff5f9bc447f4b73c5341ece8659c74cb2e68e0cd14eb982d3a831f20948250084a16c99c45afde8cc1a001959fdd5a36402400106281152f71a760a3059 SHA512 809c0f24adf914501ae9431af43caa36f72594dc686451bdd27b895cca80a51e76120a1cf191944e4b8b004d18ecc890caca9faa725cee230516bb1d0ad57415
diff --git a/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.6.ebuild b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.6.ebuild
new file mode 100644
index 000000000000..1f3018ef0e77
--- /dev/null
+++ b/xfce-extra/xfce4-battery-plugin/xfce4-battery-plugin-1.1.6.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-info xdg-utils
+
+DESCRIPTION="A battery monitor panel plugin for the Xfce desktop environment"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-battery-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-battery-plugin/
+"
+SRC_URI="https://archive.xfce.org/src/panel-plugins/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2+ LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~riscv ~x86"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0:2
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.16.0:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+pkg_setup() {
+ if use kernel_linux; then
+ CONFIG_CHECK="~ACPI_BATTERY"
+ linux-info_pkg_setup
+ fi
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}