summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-11 19:36:29 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-11 20:48:19 +0100
commit86f433e58cef36a80b215476ca08026c5e96a5ad (patch)
tree6c8703e484a67efd29af0ac1880d95b11868d013 /xfce-extra
parentapp-arch/tarlz: Bump to 0.26 (diff)
downloadgentoo-86f433e58cef36a80b215476ca08026c5e96a5ad.tar.gz
gentoo-86f433e58cef36a80b215476ca08026c5e96a5ad.tar.bz2
gentoo-86f433e58cef36a80b215476ca08026c5e96a5ad.zip
xfce-extra/xfce4-alsa-plugin: Bump to 0.4.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-alsa-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.4.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-alsa-plugin/Manifest b/xfce-extra/xfce4-alsa-plugin/Manifest
index f4e3988ce881..dc1ae9399a4b 100644
--- a/xfce-extra/xfce4-alsa-plugin/Manifest
+++ b/xfce-extra/xfce4-alsa-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-alsa-plugin-0.3.0.tar.gz 28277 BLAKE2B e821276a80a4fbb245a21b53e16fd85bf0de9010ba848329639b2f8ea00fb85288b2799a1ea97eb6004963c6915fc4cf8ec8ea9c5b87c3cc8dc1a482a7e52d9d SHA512 ed6a99ddf5fb1d3bef5b0741c94127ac48d6b2bd0bfc5ace9416302f6780692ed21e5f0ccff4758b915aefc2288fbf2b7e6671ee6cb26e4e57c44a6409dda08f
+DIST xfce4-alsa-plugin-0.4.0.tar.gz 49696 BLAKE2B acf4fdbb50b4d39c52dbca7828169dcb2d9e3fd1156541a5cf58f3c8ab9e71d6b062a214a5a14301fa2c7d190b3efec5bec131622ad1aa3c9a321776ef6a8652 SHA512 cb31e578ec283fba8822c6407f6676351bc8e83a2884969dfb938422d879994cdd96d0c027d3a6bf737ec4c3317e29ed55e8b6b017d0760362b031c5d94e060f
diff --git a/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.4.0.ebuild b/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.4.0.ebuild
new file mode 100644
index 000000000000..1a7b8b3b5411
--- /dev/null
+++ b/xfce-extra/xfce4-alsa-plugin/xfce4-alsa-plugin-0.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vala meson
+
+DESCRIPTION="Simple ALSA volume control for xfce4-panel"
+HOMEPAGE="https://github.com/equeim/xfce4-alsa-plugin"
+SRC_URI="https://github.com/equeim/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ media-libs/alsa-lib
+ >=xfce-base/xfce4-panel-4.13
+ x11-libs/gtk+:3[introspection]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ $(vala_depend)
+ sys-devel/gettext
+"
+
+src_configure() {
+ vala_setup
+ meson_src_configure
+}