summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-12-29 15:23:39 +0100
committerMichał Górny <mgorny@gentoo.org>2024-12-29 15:23:39 +0100
commiteb1bc29e548d34632eaad9a4db0ee86c28d30d8e (patch)
treeb80a49c76e6e287872918b1a441f6cb9fb07fc98 /xfce-extra
parentxfce-extra/xfce4-xkb-plugin: Bump to 0.8.4 (diff)
downloadgentoo-eb1bc29e548d34632eaad9a4db0ee86c28d30d8e.tar.gz
gentoo-eb1bc29e548d34632eaad9a4db0ee86c28d30d8e.tar.bz2
gentoo-eb1bc29e548d34632eaad9a4db0ee86c28d30d8e.zip
xfce-extra/xfce4-notes-plugin: Bump to 1.11.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-extra')
-rw-r--r--xfce-extra/xfce4-notes-plugin/Manifest1
-rw-r--r--xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.11.1.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/xfce-extra/xfce4-notes-plugin/Manifest b/xfce-extra/xfce4-notes-plugin/Manifest
index 7518aaa7f257..e256e95690d2 100644
--- a/xfce-extra/xfce4-notes-plugin/Manifest
+++ b/xfce-extra/xfce4-notes-plugin/Manifest
@@ -1 +1,2 @@
DIST xfce4-notes-plugin-1.11.0.tar.bz2 524627 BLAKE2B f2d09bb460683169f73e35c7bdb7be0273acfd3a7ecac04bedaec6e4b91aeedc3400eaa10b08a5b632f845afa647851417bb2b5b3426360d0808bcc9bd733696 SHA512 3644049bb2aa77bbed5b391f47d67dbf6528cb535448287a28a011d78a6fb31971a3556fe37ad380858d2b561ef67fee2bc93c4ed0c19c75c564d832cd4d47f1
+DIST xfce4-notes-plugin-1.11.1.tar.bz2 622941 BLAKE2B 031fbfcae6f220ec910f1ee46c484ff271e3d74bc08f91c416eedf87343cdd4c027285d00b43e43ef4d01357a55960b1c3c5fc15d3239113834c26d03908ed0a SHA512 7d81c3535a8c8dea922d88cf8bc3498db5c3f4b49aff1a4bc6c34ec93dc37381dd97403202e2828af521045445848cd72ccce5436b5fa24b567a68a6f4cb42dc
diff --git a/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.11.1.ebuild b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.11.1.ebuild
new file mode 100644
index 000000000000..8c7d132c686c
--- /dev/null
+++ b/xfce-extra/xfce4-notes-plugin/xfce4-notes-plugin-1.11.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit xdg-utils
+
+DESCRIPTION="Xfce4 panel sticky notes plugin"
+HOMEPAGE="
+ https://docs.xfce.org/panel-plugins/xfce4-notes-plugin/start
+ https://gitlab.xfce.org/panel-plugins/xfce4-notes-plugin/
+"
+SRC_URI="
+ https://archive.xfce.org/src/panel-plugins/${PN}/$(ver_cut 1-2)/${P}.tar.bz2
+"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+DEPEND="
+ >=dev-libs/glib-2.50.0:2
+ >=x11-libs/gtk+-3.22.0:3
+ >=xfce-base/libxfce4ui-4.16.0:=
+ >=xfce-base/libxfce4util-4.16.0:=
+ >=xfce-base/xfce4-panel-4.16.0:=
+ >=xfce-base/xfconf-4.16.0:=
+"
+RDEPEND="
+ ${DEPEND}
+"
+BDEPEND="
+ dev-util/intltool
+ virtual/pkgconfig
+"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}